Clipping / small pops when changing tracks on Roon App

I just received a audio server from my vendor and love it over all. It’s on Intel I7 with max ram of 8gB.

Audio Server:

-There is an small pop/clipping noise when I manually switch tracks,

  • if track is automatically switched by roon , it is an smooth change with NO clipping/ pop noise from speakers.

My Set up: RS9 is connected to a passive switche /dumb switch along with Marantz S7015 and Marantz is roon ready.

I use the latest Roon App on my iPhone.

Here is a link to download my test

Here is a sample the small pop noise occurs at 7:25 , 12:37, 15:83 ,20:97 ,25:77 (end of track ), 27:60 and so on

Appreciate every one’s suggestion here as the pop noise when tracks changed manually is quite annoying.

is the bit rate or format changing at the time of the clicks…if so this is probably the cause and the zone is not handing the change silently.

FYI I dont think Marantz is RoonReady … see Partners - Roon Labs RoonTested perhaps depending on the model

1 Like

any idea how to check if the format is changing when I click the song ?

use the signal path window

1 Like

Bit rate remains the same across all tracks.

An alternative method would be to change the re-synch delay which introduces a small (configurable) delay to allow a Dac switch between bit rates. I had a similar problem which was resolved using this method.

This costs a few seconds of your time so is worth a try.

Resync delay
This setting is primarily used when an S/PDIF, AES, or I2S connection is involved. Oftentimes, a DAC will take a little bit of time to lock onto a new audio signal–sometimes as long as a few seconds.
This setting causes Roon to play a configurable duration of silence whenever it begins a new stream. Like the last setting, this one is a problem solver. If you find that the beginnings of songs are being cut off, or you’re getting a lot of clicks and pops while your DAC locks on to an S/PDIF signal at the start of playback, try increasing this setting. 500ms is a good starting point. If that doesn’t work, try gradually increasing it from there.
We default this to a very small value because it produces delays in Roon’s user experience. Consider that when setting it up–unless you have an uncommonly slow DAC, settings longer than 1-2 seconds are probably not necessary.


you are using airplay… not ideal and perhaps not gapless (not sure) but roon could be resampling to 16b/48k to support the apple airplay

1 Like

If you can hear it, then its analog. Looks like your Marantz SR7015 is responsible for everything analog in your setup.

There is no certification for brands, just for specific equipment/devices. There is not a single Roon Ready device offered by Marantz. Some Marantz devices are Roon Tested however for their AirPlay support.



Note: The SR7015 isn’t even listed though on Roon’s partner site.

Maybe the manual track switching leads to a short interruption in the stream, I don’t know the details about Roon’s streaming/AirPlay implementation well enough to know for certain, and the pop is something you can hear because of that. As I really don’t know anything about the innards of your Marantz, this may happen for various (like for example input switching) reasons. You can possibly test for that by just switching inputs on the Marantz without playing music and listen for pops.

1 Like

Ironically when I transfer the song to my iPhone , the path certain changes multiple times , though there is no clicking popping from I phone speakers …

A different AirPlay implementation (no longer the one from Roon is used) may behave differently regarding connects/disconnects of the stream/device.

1 Like

Next option would be to connect my audio server RS9 directly via USB to Marantz , not a big fan of direct connection via UsB , I guess there is no fix for this clicking noise as we have no control over it

If I’ve read the manual correctly (10 minutes ago) then there is no USB audio input, just a front USB connector for storage devices.

1 Like

I’ll give this a try ,

Thank you,

1 Like

You are correct , I just checked and there is no USB in…. Wow!

I would suggest for the best sound you either go HDMI from the core to the AVR or get a USB/Networked DAC and go in via RCA inputs

the latter is probably best but requires more than just an HDMI connection.


I try to explain my theory in more detail:

Most devices that implement AirPlay (or ChromeCast) use auto input switching for this protocol meant to be used from mobile devices (to avoid users have to walk to the device or have to pickup another remote). Users also deliberately choose that connection and stay connected until they disconnect. In the case someone forgets to disconnect and just walks away (leaves home for work) the connections gets broken. Devices usually return to a default or the last used input on disconnects.

Roon on the other hand (has to) choose some sort of on-demand connection when it gets instructed to play to a device and probably immediately disconnects when the music stops. Imagine they would connect already just because a user selects the device as zone in its Roon Remote and would stay connect unless he switches to another, non-AirPlay zone. The respective audio device would be locked into AirPlay mode hindering users to (easily) use their devices with other inputs. Imagine a user who’s only Roon zone is a receiver over AirPlay. He has no other Zone to switch to. With an always-on Roon Core the receiver would be locked into AirPlay mode eternally. So Roon connects on-demand when playing.
While Roon is playing on its own (albums, playlists, radio) it knows, if there is a “next” track to be played or not and stays connected. If you play single tracks and then choose another after the current one finished, Roon will disconnect from the audio device and then reconnect again when start playing the new track. Track skipping is probably treated like a special case of that – or it might depend where you are when skipping. That’s where I don’t know the details of Roon’s implementation and also can’t test because of lack of devices.

But anyway, as far as I understand the matter at hand, the actual popping sound is generated inside the Marantz and not through Roon. Maybe – just maybe – there might be potential for Roon to do better regarding stream interruptions but even if there is and that potential would be utilized at some point, this would not make the issue go away completely.

1 Like

There is no USB input on your Marantz. If you really want to use the Marantz with Roon your best option is via HDMI from a Roon bridge to your Marantz or via a Roon Ready streamer with coax/toslink outputs.

1 Like

As far as I understand the matter, I’d have to disagree, but we neither know for sure, nor is my situation the same…

… since I’m using USB from core to DAC, but also very often hear more or less loud pops or tics when skipping within or through songs.

The existence and the loudness level of these artifacts is dependant on the exact time of skipping within a song.

I’m pretty convinced that the problem lies with Roon ungracefully jumping from a certain signal level to a different one or even zero within just one sample.
Doing it gracefully would require to wait for a signal zero-crossing occurrence.

I’ve tested my theory with a digital zero file that I’m replaying, and there are no artifacts to be heard when skipping.

IIRC, there’s even been a Roon developer statement somewhere in the “fade-in fade-out…” feature suggestion thread, saying that the RAAT implementation would need significant coding changes to do anything other than cutting the stream the hard way when skipping in any form.
Changing RAAT’s code bears enormous consequences for all Roon Ready devices incorporating it in their firmwares, thusly it probably won’t ever happen…


I edit my post to (hopefully) make it clear that I was commenting on the topic of the OP and not something else.

Thank you for confirming that Roon doesn’t add anything to the signal.


Hey guys,

Had a discussion with my vendor and we decided to by pass the air play , convert the digital to analog on an external DAC and send the analog signal to Marantz via RCA. This has resulted in much better sound quality and no pop/ clicking noise between tracks

1 Like