Complete mess after latest update

Roon Core Machine

Rock on Intel NUC (nothing changed)

Networking Gear & Setup Details

Rock, NAS and one BlueSound Node 2i connected via LAN, another Node 2i via WLAN (nothing changed)

Connected Audio Devices

BlueSound Node 2i (nothing changed)

Number of Tracks in Library

ca, 5200 (nothing changed)

Description of Issue

After 1.8 update nothing really works anymore…It started that the Core did not restart after update. “Not found”… No contact… I had to restart the NUC by pulling the power supply.
Next effect: “Cannot login to TIDAL”. Every application else in the network could, so it was not due to TIDAL or my network or whatever. Took some time with different attempts to relog-in, till it finally worked.
Next effect: Could not play any song from my library. They were shown under “titles”, but could not be accessed. No success in trying to tell Roon now, where my library is located. I deleted the library directory entry, and re-entered it, but it keeps empty.

No further ideas what to do…

Just to confirm my own environment: if I run music via the BlueOS app for the Bluesound Nodes, it works fine either with TIDAL or with my own library. Not any problem.

Diethard (Germany)

1 Like

Well, some news!

Somehow I made it that Roon started indexing my library again! Yeah! It went quite fast showing now:
Realtime monitoring of new files
5447 titles imported

Wow, that looked good. So I went selecting “Titles” from “My Library” and there were all my missing titles displayed. So I started the “My Titles” “Random playback”, the first title was shown, 4:27 playtime, the cover of the LP, but… well, nothing happens, the normaly blue or green dot on the left is gray, where I can see the source (either library or TIDAL) and the steps of processing, it’s completely empty. it just shows BlueSound Node 2i and Audeze LCD-2 as final steps (of nothing…).

Not a real progress…

Hi @Diethard_Wehn,

I’m very sorry to hear that these issues have sprung up and are causing such a headache. We appreciate you posting in Community to let us know.

I have just a few questions to diagnose what might be going wrong.

  1. Would you please elaborate a little on your network setup and how it’s all connected? Please include your router model and any switches or access points you’re using for your WLAN.

  2. Are you experiencing these issues on multiple Remotes, or is it specific to one device?

  3. Are you running the same build of Roon across all your devices? If you haven’t already, try uninstalling and reinstalling the Roon app on your Remotes before rebooting.

  4. Would you mind sending a screenshot of your watched folders? In Roon, navigate to Settings → Storage to show your watched folders and network share settings. Here are instructions for posting a screenshot to Community.

Once we know the details of your network setup, we’ll proceed with additional troubleshooting steps until we resolve the problem. Thank you for your patience - I know how frustrating it is to go without a working setup.

Hi connor,

thanks for your reply.

  1. My networt setup hasn’t changed for ca. 2 years, and everything is working absolutely fine. It’s a AVM Fritz 6490 cable router, 250 Mb/s connection, several devices (Windows PCs, printer, Synology NAS, one Bluesound Node 2i, 2 AVM network players via Chromecast, and Roon Core on Intel NUC Kit NUC8i3BEH) connected via LAN, as well as 2 mobiles, Samsung tablet S6, another Bluesound Node 2i, AVM Mesh Repeater 1200 connected via LAN.

  2. I have the issues on all remotes (the 2 Bluesound Node 2i and the 2 network players connected via Chromecast). TIDAL is working as well as internet radio, but no more access to my music library on NAS. Access to this directory via Windows explorer is fine.

  3. I use a Samsung Galaxy S20 FE and a Samsung Galaxy S6 Tablet as remotes for Roon. Both are uptodate, 1.8 from 27.4.2022.

  4. Here they are. Interesting might be the second one under “Library” (I translate from German): Speed of background analysis: limited (which seems to be OK, changes don’t make a difference). But below this it shows “Analysing: 0/1” for hours and makes no progress. So I think here is the fault!

When I try to reset the Roon Database and Settings, I will get an error.

Hi @Diethard_Wehn,

I appreciate the thoroughness and detail of your response. While the issue likely isn’t a local network problem, knowing the full details of network hardware helps to eliminate variables so my team can trace the problem more efficiently.

The error message from your last screenshot suggests you may have the Data folder from your RoonOS device mounted to your desktop computer while you’re attempting to reset the database. If so, please unmount it and then reboot your Mac/PC before attempting the reset again.

Also, please take note that resetting your database will wipe out all settings and your entire existing Roon database. It’s a heavy-handed step but should resolve the issue. Before proceeding, be sure that you have a recent backup (unless you’re willing to rebuild your library and all saved settings).

Thanks again, connor, for your fast response.

Well, “stranger things” happen over here (with a tendency to get better :wink: ).

No, I did not mount anything from the NUC to my PC. (Never thought of, and now I’m surprised that the NUC isn’t shown in the Windows Explorer network view, but anyhow, I tried to access it via its IP, and that worked).

What I found was that my backup programm, which makes a weekly backup of my music library to another drive, had a problem to access one of the ~5400 files. Well, I deleted the whole directory and, taking a look at my Roon app, found Roon to reindex my library.

Yeah! Solved! – Or not? Well…

There are about 5400 FLAC in my library, and Roon now says "Connected / Indexing… / 1008 titles imported / 977 files read

And nothing happens any more… What’s the progress: If I start to listen to my music via “My Library - Titles - Random replay” Roon generated a queue with 1370 titles (maybe there are some library titles directly from Tidal, not my drive) and plays also my files from NAS.

So the question is now: why did Roon stop indexing before the end and how can I force a new indexing? Hm, I copied some new FLACs onto my NAS, but Roon doesn’t care about this. Normally Roon shows “realtime monitoring” of the library dicrectory, but not now.

Well, the current problem seems to be that the reindexing of the complete NAS directory is failing and stopping - no idea why. Maybe due to problems on the NAS side (that’s been running for years without any problems…).

What could I do?

Regards from Germany,

1 Like

Wow, coming back from the fitness studio, I thought I’d take a look. And what did I see?

Realtime monitoring for new files
5445 titles imported

Looks good! Started my usual random playlist: queue showing 13:01:24:40, also looking good. Started playing: worked!

Why? No idea.

So up to now no problems any more. It’s magic.

I come back to you, when there are some more “stranger things”. Thanks for now.

1 Like

Hi @Diethard_Wehn,

Fantastic news. Thank you for circling back to let us know.

Reviewing our thread, it does sound like the root of the issue was the Core losing the network mount with all your files, which the database reset should have resolved (despite the reindexing holdup).

While I’m thrilled to hear your setup is working now, please reach back out in a new thread if you encounter issues or any issues with your database or network again. We’ll be here to support.

Roon currently is busy to analyze all songs of the library, 835/4411 right now, so it will take some more hours to complete. So it does what it should. BTW, I did not reset the database in the end.
Thanks again for your lightning fast support.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.