Configure MP3 codec? Playback gaps in Roon but not in foobar

Roon Core Machine

Barebones, Win11 Pro, Intel i7-12700, 32G

Networking Gear & Setup Details

Asus router, Ethernet

Connected Audio Devices

USB Focusrite Scarlet 2i/2

Number of Tracks in Library


Description of Issue

How can I tell which mp3 codec Roon is using when it decodes playback? I’m trying to debug micro-gaps between tracks. When I play tracks in foobar2000 and MediaMonkey there aren’t any audible gaps, but when I play the same tracks in Roon, I get microgaps. I’m thinking either they are using different codecs or Roon isn’t reading the mp3 metadata on playback.

The issue occurs on my local machine and in ARC.

It began happening a couple of months ago when I switched from an older machine to my new platform.

Any help would be appreciated.


There isn’t different mp3 codecs mp3 is the codec, there are different mp3 decoder algorithms that if included in a commercial product need to be licensed in case of Roon it lets the licensed os decoder do it, foobar uses Lame I believe and media monkey uses Windows decoder like Roon by default.

1 Like

I greatly appreciate the response.

It is strange that Roon and Mediamonkey use the same codec yet MM plays gapless but Roon does not.

I was hoping to find a configuration where I could specify a path to use a different codec - a la dbpoweramp.

I guess no one has figured out a way to play mp3 files on Roon w/o gaps.


Can’t say I have noticed any gaps with mp3 gapless I have just tried now no gaps. I don’t use windows though as I use a ROCK based core which requires ffmpeg mp3 decoding.

Are these cd rips or purchased files?

I guess more likely that nobody else experienced the problem :slight_smile: Or are there older threads about it?

He seems to be having dropouts within tracks, not gaps between tracks, if I read the OP correctly

I read that differently as being micro gaps where it would be gapless. Either way I don’t get any issues at all with mp3 files.

It says “in tracks” but yeah I don’t know :slight_smile:

I ran Roon for years on Win10 and didn’t experience mp3 playback gaps. I’m experiencing it now after moving to a win11 platform a few months ago.

I checked the old threads to see if others were reporting the same problem but haven’t seen it.


Sorry. I must have been tired when I wrote the above. Micro gaps between tracks. I’ll fix it.

Thanks for pointing that out.


Same for me. No issues playing gapless mp3 files. Using ROCK.

WIN11 here also - if needed, retrieve my full system configuration by clicking my avatar.
Triggered by this report, I just tested my setup and…

  • there are MP3 albums with about a tenth of a second gap between songs that, I’d almost swear, used to be gapless in Roon in the past.
    BTW, these also play with gap in current WIN11 media player, as well as using LMS on same server.
  • there are MP3 albums that do still play gapless!

Happy to supply sample albums to support, if needed to investigate…


Thank you for the reply. That’s exactly what I’m hearing. A tiny gap between tracks. Maybe Microsoft changed the codec. I’m also hearing it in the Win11 media player and the legacy, but not foobar nor MM.

I see you’re still running Squeezebox radios. I had one, but it died about 4 years ago :frowning: I’m still running a Touch and a Slim Devices Classic though. Those are great products.

Hi @Jon_Poletti ,

Can you please check to see if the Roon release from today helped with this issue?

Hi Noris,

It looks like the new releases solved the problem I was having. Hurray!

Thank you!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.