Confused about upsampling in DSP engine [Resolved]

I have a new system which consists of a powerful server feeding a microRendu which feeds a Kii Control (USB) and of course, a Kii system/speakers.

If I use Roon to feed the HQP NAA mode on my mRendu, I can upsample to PCM rates as high as 384k. The DAC in the Kii"s is capable of working with DXD type rates.

If I switch the mRendu to RoonReady mode, the highest PCM rates that appear in the resampling engine are 192. Interestingly, DSD 256 appears there, even though the Kii can’t handle DSD above DSD 128. But no PCM upsampling options of 352 and 384 appear.

I was under the impression Roon was capable of upsampling to those DXD rates if the device it is connected to can handle those rates. Is this incorrect?

Probably a stupid question, but did you set the sample rate conversion settings, et. al. in DSP settings?

Yes, of course. My question is that I understood that Roon should upsample to 352 and 384 rates if your DAC can handle it.
Mine can, but Roon only shows PCM rates up to 192.

Ah, sorry, misunderstand your post. I thought you were saying you couldn’t upsample to DSD. Apologies.

Tagging @support.

(I covet that Kii system.)

In the microRendu’s settings, are you using DoP?

What happens if you plug the Kii system directly into the server? Any change in the supported sampled sample rates?

DOP- on off doesn’t make a diference
Direct connection from server to Kii control:
Interesting: the server recognizes the Kii Control as the sound output, and I can successfully playback outside of Roon.
Roon doesn’t see the Kii Control at all in this scenario -it doesn’t appear as a zone.
I tried restrtarting the server running RoonServer, and also the Kii Control - Roon still doesn’t see it. Windows does. It’s W10.

The Kii is USB 2 audio compliant and driverless so this is very odd.

Can you post the information in Settings/ System Settings / Custom DAC?

  1. USB Audio Class Digital alsa audio output interface `hw:0,0’
  • device name = Kii Control
  • interface name = USB Audio
  • usb audio class = 2 - isochronous asynchronous
  • USB ID = /proc/asound/card0/usbid
  • character device = /dev/snd/pcmC0D0p
  • encoding formats = S32_LE, S16_LE
  • monitor file = /proc/asound/card0/pcm0p/sub0/hw_params
  • stream file = /proc/asound/card0/stream0

Okay, Jesus, you are off the hook on this one. Turns out there is a setting in “playback” under “zones” (not DSP engine) that limits max sample rate. I had to change this setting and everything with the mR, Kii, and Roon works as it should.

But if I directly connect my RoonServer over USB to the Kii Control, Roon still doesn’t see the Kii as a DAC\Soundcard.
Under this scenario, in W10 the Kii is defined as the default “sound” output and shows the ability to play up to 384khz. In playback software other than Roon, playback works.

If you are going to use a PC connected to your DAC you might need to install software drivers that came with it. Post a screenshot of the Roon Settings / Audio so we can see what devices are listed.

Okay, figured this out too, now. Jesus’ question made me realize what the solution could be.

My server has several possible sound “outs”. One is called “system output”. It always appears in Roon - even before I had this setup with the Kii.
Previously, every device that had a unique name in the Windows sound outputs showed up with that name in Roon.

But for some reason, the device that is called “Kii Control” in Windows is what appears as the “system output” in Roon. Until now I thought this was the same device that had always been there (built in sound in Windows) and not the new Kii,

So sorry for all the trouble. Roon is fine and everything works. I just didn’t understand all the setup possibilities.