Connect PS Audio

I am trying to connect my PS Audio player with the Bridge. I can play from other software, although i usually need to manually type in the IP address the first time (which is 192.168.2.xx). I can’t figure out how to do that in Roon. Your UI doesn’t seem to allow manually adding the IP address which i find very confusing. @support

Hi @Michael_Fricklas ----- Thank you for the post and sorry to hear of the troubles.

While it is a touch unclear to me as to what PS Audio device you are currently using, the PS Audio DirectStream, DirectStream JR, and the Perfect Wave are all certified as “Roon ready” devices as mentioned here in our Knowledge Base.

In short this means that when they communicate with Roon they are making use of our streaming Protocol, “RAAT Server”. Thus the application should be able to identify the DAC on the network without any other setup required (i.e manually entering IP addresses etc).

May I kindly ask you to please post a screenshot of your “audio” tab in Roon so we can see which device are being identified on your network within Roon. Furthermore, can you please also confirm the model of PS Audio device you are currently using and that all the firmware is up to date.


Hi - is’s the perfectwave DAC with a Bridge mk.ii installed and upto date software (firmware 2.4.3)

The audio page shows no network attached devices - only shows “System Output” and “RealTek High Def”

I have no trouble streaming to the perfectwave from other software, but other software also can’t find it without help. For example, JRiver software was able to find it as was my Synology streaming software, but only after i added manually. Similarly, my wifi connected laptop could find it but only with manually entering the IP address. It’s possible that the device (or my network) is set in a way that makes it hard to find an ip address by simply scanning for security reasons.

Thus - the need to enter the IP address.

Sounds like your network has a problem. You really should be able to search by device name.

Hello @Michael_Fricklas,

Can you please let us know your network gear here? Please list the model/manufacturer of your Router, any Switches, Powerline Extenders, ect. so that we can have an overview of your devices. You mention that you have to manually type the IP address of your PS Audio player, are you using two Routers in your setup?

I would focus on getting all of your devices on one network and one subnet range (possibly 192.168.2.XXX as you have mentioned). You should be able to apply this setting in your router’s configuration page and if you have a secondary router, I would disable the DHCP features of that secondary one as to prevent any communications issues in the future and let the main router handle the DHCP addressing. Our Networking Best Practices Guide highlights this information and a few other useful guidelines.

Please let me know your model/manufacturer for the network gear you’re using here and I can check to see if there is an instructional manual how to configure the network as per my above suggestions.


Fios Quantum Gateway is the router.
It’s at
My computer is at 192.168.X.X.
The Ps Audio is hardwired ethernet at; address Allocation DHCP
Oppo BDP 105 is hardwired ethernet static at

Only the router is allowed to assign addresses although there are a couple of access points in my home network and some netgear dumb switches.

My network map (accessed through the home page of router) shows the network devices just fine.

Sorry computer (with Roon running) is at So all devices are within the 192.168.2.x address assignment

Hello @Michael_Fricklas,

Can you please let me know what kind of Access Points you are using in your setup? I am wondering if you have accidentally created multiple network segments and this could be why you are having device discovery issues.

As a test, I would try connecting both your Core and your PS Audio device directly to your Router via Ethernet, does the DAC show up properly after doing so? If it still does not show up when connecting directly to the Router, I would then take a look at your Multicast settings for the Router or your Firewall settings and make sure that Roon is allowed to access to the network.

If you are using Windows, I would double check that both Roon and RAAT are listed as exceptions in your Windows Defender Firewall and if you have any Antivirus Software running (McAFee/AVG) or Firewall Software (Little Snitch/Bullguard), I would try temporarily disabling those as well to see if this has any change.

Please let me know your findings from my suggestions above.


Sorry just saw this here. It was different network segments and it’s all working now. The PS Audio is wired - and wifi was through a BitDefender Box. Got rid of the box, set up wifi with Eero, turned off the wifi direct from the router (so only eero is being used) and everything works fine.

1 Like

Hi @Michael_Fricklas,

Thanks for the update and glad to hear you managed to resolved this issue!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.