Connecting to Cocktail Audio X45

Core Machine (Operating system/System info/Roon build number)

MS Surface with Win10

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Verizon Fios ethernet connected directly to the router

Description Of Issue

I have my Surface tablet setup as the Roon Core. My CA X45 is connected to my LAN via ethernet. How do I get Roon to connect to the X45?

Hello @Walt_Lederle,

Go to the Settings > Audio screen in Roon, scroll down until you see the cocktailAudio X45 under the “Roon Ready” heading, then click “Enable” next to the X45 entry.

You can see all of your enabled zones by clicking on the “zone” icon to the left of the volume icon, both located the bottom right hand corner of the screen.

If you are on a smaller screen, you may need to click the volume icon and then tap “switch zones” to see the zone picker screen.


1 Like

Thanks John,

I do see the Cocktail Audio X45 in the Roon Zone, so I do believe I was successful in making that happen.

I still, unfortunately, cannot get my music files from the X45 over to the Roon Core. I’ve tried to “add network share” in the Storage menu under Settings but must be doing something wrong. How do I get Roon to connect to my X45? The Roon Core is on my MS Surface tablet running Win10 connected via wireless wifi to my router. The X45 is connected to the same router wired with an ethernet cable. The X45 does have internet connectivity as it is successfully downloading album art, etc.

I hope I can get Roon to read from my X45.



Hi @Walt_Lederie,

Have you made sure to enable your Samba share on the X45 prior to trying to add it as a storage device? I would suggest looking over the Cocktail Audio X45 Manual, specifically on page 49 for instructions on how to enable and access the Samba share.

After enabling the share, then on the Roon side you would need to add the share location, typically this is smb://HOSTNAME/SHARENAME or \\HOSTNAME\SHARENAME. Please take a look at the examples from the bottom of the page. I would try connecting as a “guest” if connecting without a username/password is not working.


I have tried several different combos of what we are prompted to enter when trying to connect the HDD from the X45 on the network to Roon core on my laptop

Can you tell me where to get (please, where do I get this information to enter into Roon, not, “it’s usually”, i’ve read the manual)

Network Share Location
User Name
Work Group

Hi @Agrippa,

Did you review the manual I sent above?

This would be the hostname / IP you specify on the X45 menu, and the SHARENAME should be replaced with the actual folder name.

I believe by default they would be guest for both.

This is configured in the X45 menu, just like hostname.

Please look over section 4-5-1 Samba Server which is on page 49 of the manual I linked above for the SMB info.

ok, using the IP seems to have done something (smb:// and I retrieved the Work Group name from the samba server setting, but now it says “unauthorized”. I tried using the ftp user name and password i set up for FTP transfer (which I can connect with) and it still says unauthorized, same using blanks and same using guest guest for both.

Any idea on next steps?

Hi @Agrippa,

I am unable to find a default password for SMB credentials in the manual, if guest for both username and password does not work, I would reach out directly to Cocktail audio to see if they can provide the appropriate login for your X45 Samba Server.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.