Connecting to roon server on ubuntu VM machine [Resolved]

I have roon server running on a Ubuntu 16.04 virtualbox on a freenas server. I assume the roonserver is running properly since i see “roonserver” and “roonappliance” processes in the system monitor program. I ran the script and all the dependencies are there. I am assuming there is no GUI on the linux side, but rather the server has to be administered from a client device like an android tablet.

My problem is that i have no clue how to connect to this virtualbox server from a remote client. When I had roonserver previously running on a “real” windows7 box the remote client would magically find the server and everything worked. don’t know if this is a firewall or network problem or some other issue. Does anyone have experience connecting to a server running on a VM?


Yes I’m running RoonServer on a Debian VM (KVM-qemu) with no gui. It works fine, but I’m using a bridged Ethernet connection instead of NAT, so the server and all the clients are in the same subnet.

Thanks for the reply. Are you using virtualbox or some other VM utility? I am wondering if you could add more detail about how this network is setup?

As Erik said, this is almost certainly a NAT issue. You need to set up your VM in bridged mode.

Check what subnet your VM is running on by typing ifconfig in a terminal window of your Ubuntu install.

Hi guys. You are correct! I setup the VM in bridged mode and the box became visible to my network. thanks for the help!

1 Like