Connection failed and Chromecast issues: Roon using new/additional network ports since 880

Thanks for sharing.

This solved the connection failures to my Linux Core after the update to 880.

Thanks for the info @Eamonn_Maher
Just to be on the safe side I’ve allowed the 9330-9332 range.

I see that the Web Display URL is now using port 9330 in Build 880. Previous builds were using port 9100


Changes like these should be included in the release notes and the documentation, and not left up to users to find out on their own…


So is the expected solution for me to open ports, or for me to disable Sonos zones to get under the “7 Sonos zone cap” or for Roon to fix something? Right now have disabled a few Sonos zones, which is fine for now. Thanks so much for diagnosing.

thanks a lot Christophe this solved it for me after updating to 880.

big thanks to ROON for not specifying this in their update notes made me waste 3 hours thinking my machine was broken.

love the software but this is unacceptable levels of support or communication

1 Like

Thanks, beem struggling wirlth connecting to my Roon Core after update, allowing port 9330 - 9332 in firewall allowed me to connect again

Hey everyone :wave:,

For more information on this, I wanted to point you to Brian’s post. It explains our position on ports:

‘We just use some random ports and our users just have to figure out for themselves which ones they are’ ?
Every piece of software that uses network protocols has documentation where you can find what ports are being used, but Roon doesn’t?
I’m sorry, but this is unacceptable!
If you can’t provide this kind of technical data, this will be the last year I subscribe to Roon.

1 Like

Had some time to do a little more digging this morning…
For people having issues with Chromecast no longer functioning, Roon now uses port 9333 to stream to my Nest Mini.
I noticed on my firewall that these connections were being blocked: tcp Default deny rule
Allowing 9333 to pass through and opening the port on my Core solved the Chromecast issue.

Maybe extra ports are being used if you stream to multiple Chromecast devices, but I can’t tell for sure.

Some simple documentation around the ports being used would have saved us users hours of frustration and digging around logs…

Do I suffer from the same?
Since 880 I get strange restarts:

root@scarpe:/var/roon/RoonServer/Logs# journalctl -u  roonserver.service -f
-- Logs begin at Tue 2019-02-26 20:44:22 CET. --
dec 17 15:37:40 scarpe[3499]: Started
dec 17 15:37:40 scarpe[3499]: aac_fixed decoder found, checking libavcodec version...
dec 17 15:37:40 scarpe[3499]: has mp3float: 1, aac_fixed: 1
dec 17 15:37:45 scarpe[3499]: Running
dec 17 15:56:12 scarpe[3499]: Error
dec 17 15:56:14 scarpe[3499]: Initializing
dec 17 15:56:14 scarpe[3499]: Started
dec 17 15:56:14 scarpe[3499]: aac_fixed decoder found, checking libavcodec version...
dec 17 15:56:14 scarpe[3499]: has mp3float: 1, aac_fixed: 1
dec 17 15:56:18 scarpe[3499]: Running

The open files of the RoonAppliance process grows massive and fast:

root@scarpe:/var/roon/RoonServer/Logs# ls -1 /proc/$(pidof RoonAppliance)/fd | wc -l
root@scarpe:/var/roon/RoonServer/Logs# ls -1 /proc/$(pidof RoonAppliance)/fd | wc -l
root@scarpe:/var/roon/RoonServer/Logs# ls -1 /proc/$(pidof RoonAppliance)/fd | wc -l
root@scarpe:/var/roon/RoonServer/Logs# ls -1 /proc/$(pidof RoonAppliance)/fd | wc -l

Lots of:

12/17 15:58:25 Critical: scx: in OnExit: System.Net.Sockets.SocketException (98): Address already in use
   at Sooloos.Http.HttpServer._Start()
   at Sooloos.Broker.Transport.CastZonePlayer..ctor(State state, IEnumerable`1 realeps, IEnumerable`1 endpoints)
   at Sooloos.Broker.Transport.ZonePlayerFactory.Create(State state, IEnumerable`1 endpoints)
   at Sooloos.Broker.Transport.Zone.LL_UpdateEndpoints(Boolean first)
   at Sooloos.Broker.Transport.Zone..ctor(State state, Module module, Sooid zoneid, IEnumerable`1 endpoints)
   at Sooloos.Broker.Transport.Module.ev_threadexit()
   at Sooloos.SynchronizationContextThread.OnExit()

And after a while:

RoonServer_log.20.txt:12/17 14:41:36 Debug: NotifyCorruptZoneDatabases Exception LevelDb.Exception: IO error: /var/roon/RoonServer/Database/Core/5d5b0749cc6e455194aca11ab9ed0c4d/transport/zone_16015a8849ba9e0f538753043adb67708409.db/CURRENT: Too many open files

I never used iptables or other FWs on my core. Never had these kinds of issues before the upgrade.
It just seems seriously broken.

I don’t think it’s related, I’ve checked my logs and Roon never crashed.
My remotes started working right away as I opened the necessary ports on my firewall

For posterity, and if anyone with similar problems should find this post:
I’ve been able to narrow down the ports my setup uses to tcp 9330:9339 and udp 1900,9003. If you want chromecast to work, it seems you’ll also have to open tcp 8008,8009 and udp 32768:65535
Opening these fixed all connection issues for me.

Hopefully Roon doesn’t pull some different port numbers out of it’s hat with every new release…

Does it still work with Roon 1.8 build 882?
Here Chromecast audio was working fine with firewall rules. Now updated to build 882 when I hit play, it won’t… when I disable the firewall it works. Looks like a new port to add?

Hi @Ramon_Laponder , you seem to be correct.
I’ve updated to 882 this evening and was also having issues…
Looking to the connections, I’m seeing attempts to connect to ports like 30000 and 30002.

These are the rules that I have currently active.
roon_ep is the alias for my roon endpoints and trustedsubnets are the euh well… trusted subnets in my network :wink:
If you don’t use vlan’s and don’t have fixed ip’s for your endpoints and/or remotes, you can ignore these and just allow all ip’s from within your network

It might not be necessary to have the 32768:65535 udp and 8008:8009 tcp ports open, but it’s saturday 23.00 here and now that it’s sort of working, I’d rather spend my time listening to music and drinking than figuring out this mess :smiley:

1 Like

I also have this issue on Ubuntu. However, I must be ,missing something, because I can’t connect the Windows or Android app without disabling the firewall.

1 Like

For Linux based Core server, if you’re running something like UFW firewall, you may need to open the ports. Something like:
sudo ufw allow 9330:9339/tcp


@Christophe_Saelens Yeah! Thnx! That works. adding 30000 30010 to the firewall fixed the problem. Thank you very much for your help

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.