Connection issue on NUC12

Have installed Roon on NUC12WSHi7 and have this message. Anyone have the same issue?

1 Like


This suggests the NUC can’t get an IP address from your router.

Can you double check that the NUC is hardwired to the LAN.

On the NUC’s RJ45 port what at the LEDs doing?

There is no led blinking on the nuc

Can you try a different Ethernet cable?
Are you sure the one you are using is securely locked in at the nuc and the router/modem/switch it’s connected to?
And that Ethernet is live at that port.

I have tested the cable and router using a laptop and it works so I think it comes from the NUC. I was just curious if someone have the same issue as me …

DHCP enabled at your router?

That NUC12 model uses this ethernet controller: Intel® Ethernet Controller i225-V. So it’s a 2.5GB controller. Now according to Intel’s support site, there’s no Linux drivers available for this controller:

No mention of Linux support here:

The drivers come in a large multi-pack zip file with this disclaimer:


This. zip file contains all of the Intel® Ethernet network drivers and software for currently supported versions of Windows*, Linux*, and FreeBSD* for most Intel® Ethernet Adapters. Not all Intel® Ethernet Adapters and Intel® Ethernet Controllers are supported under every version of Windows, Linux, or FreeBSD.

I’ve had a dig through the v28 driver pack and can’t see any Linux drivers for this ethernet controller. Has anybody managed to get ROCK to run on this particular NUC model for sure?

Edit If there are driver problems, then this looks promising:

There looks to have been some fun and games with power saving settings and this controller.

1 Like

This is interesting - I’ve just built a NUC12WSKi3 system running Windows 11 for a friend. I found that the Windows installer didn’t have a suitable ethernet driver included for this hardware. When it got to the point where it needed to phone home for upgrades, the process just hung. I needed to use a USB ethernet connector (using the same ethernet cable) to establish a connection to the network and complete the installation process (and download and install the necessary drivers).

So the 12th gen NUCs seem to have had major changes that affect both the ethernet and HDMI connections…

1 Like

Interesting! Thank you. Hope it will help

To test, it might be an idea to make a live USB of an up-to-date Linux distro and try it out. Something with a recent(ish) kernel should do the job, Ubuntu 22.10 is running 5.19. Prepare a live stick and give it a go. If the network controller works, then you have kernel support. If not, you have (more) problems.

I have this same NUC and ROCK works fine. I had the same problem when I moved it from my audio cabinet to near my router. I had to try three different ethernet cables before I found one that worked. These were cables that I had laying around. All of the newish ones I have tried have worked. If the lights on the ethernet jack aren’t working try another cable.


1 Like

That’s good news and interesting @Kelly_Burkhart this suggests that this has been an issue for folk:

Was there anything different about the cable that worked, e.g. CAT6 vs. CAT5?

1 Like

The two that didn’t work were years old and had been used to connect an apple airplay and a printer and worked for that purpose. I don’t know where they came from or their spec (and that is in another home so I can’t check). The cable that worked was newer cable, probably CAT6, but I don’t know for sure.

I’m at our second home now and that same NUC is connected to a switch with a fairly new cable. I just verified that is a CAT6.


Just verify the cable and it’s a CAT6. Honestly I’m tired, can’t imagine to buy something and does not work. Disappointed and frustrated. Thank you guys for your help. I will return the NUC.

I thought that when you buy a NUC from the list you would be safe:


See …

So most likely a local connection issue or faulty unit.


suggests that things aren’t always plain sailing with this particular network controller. Not Roon/ROCK’s problem but this does seem to signal an issue.


Yes, it’s not simple… I’ve seen quite a few references to this particular NUC model on this forum, which would lead me to believe quite a few are using it without issue.

The issues that I’ve read seem to be centered around ASUS motherboards. I cannot determine what MB the NUC has, but it very well could be ASUS (Intel doesn’t make motherboards, do they)? This could be a MB issue, a firmware issue, an NVM issue:

It could be a cable issue, or interaction with the switch auto speed negotiation. It could be a driver issue in ROCK. Or just a bad unit.

It’s easy to say “just go get another ethernet cable and try it”. However I have been in frustrating situations like this in the past and I don’t blame the OP for throwing his hands up and sending it back.

@Jean-Philippe_Stroeb sorry this event has left a bad taste in your mouth. I hope you find a replacement that works.

Hi Kelly,

Just to clear up some comments:

NUCs are by definition made by Intel. No Asus motherboard inside. There might be other small form factor boxes with an Asus inside, but they are not "NUC"s. Like Kleenex is one specific brand, so is a NUC.

Intel does make motherboards and have done so for decades. In fact, many other motherboard manufacturers actually use their networking chipsets.

1 Like

Thanks. I will do some other tests but it’s clear that it’s not the cables (tested CAT5 and CAT6 cables). I’m disappointed because it’s a NUC listed by Roon for core. I don’t blame Roon. It’s the second NUC I purchased and the two were faulty lol :face_with_diagonal_mouth:

1 Like