Connection problem to Cambridge 851N endpoint

Core Machine (Operating system/System info/Roon build number)

NUC8i5BEH with 16 Go ram and 512 Go SSD under Ubuntu 20

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All wired with gigabit Ethernet, dlink switch, livebox last revision switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Cambridge audio 851N network player

Description Of Issue

Hello, I got an issue using Roon on my Cambridge audio 851N network player. Sometimes I need to fully switch it off in order to see it again as a Roon endpoint on Roon remote on my iPad. It happens when I use Roon and then switch to another source, when I want to use Roon again the 851N doesn’t appear as Roon endpoint, only AirPlay. It seems that going into 851N setting and change « DSD mode compatible with Roon » value to PCM and back to DoP make the 851N endpoint visible again in Roon.
I’ve asked Cambridge about the problem and they said to ask you as they are not responsible of the Roon software inside their product.
Can you please check what is the problem and correct it ?

Hi @KelFab,

Thanks for reaching out.

What other source does this issue occur on and how are you switching between the sources? Are you using the Cambridge app?

If instead of rebooting the Cambridge, you disconnect and reconnect the Ethernet cable, does that also allow it to show up again?

Can you please confirm you have the latest firmware installed?

Thanks for your answer.
I made some more tests and figured out that in fact the problem happens when the Roon core stops, when I restart the service by example on Ubuntu or switch off / on the NUC. I forgot it but I did it several times these last days because of the new NUC setting, that may be the real cause of endpoint not appearing in Roon remote.
When it happen (core restart) and when I go back in Roon app on iPad I can’t find the 85N endpoint until I switch off / on the 851N or change the DSD mode Roon compatibility on 851N settings (it seems that it reloads the endpoint Roon service). I’ve also tested to unplug and put back the ethernet cable it doesn’t make the 851N appear as a Roon endpoint. And yes it’s the latest firmware on 851N.

Hi @KelFab,

Can you please reproduce this issue once more and let me know the exact local time + date you:

  1. Don’t see the 851N in Roon Settings -> Audio
  2. Have rebooted the Core and the 851N re-appears?

Hello, the exact sequence is :

  1. Everything is fine, Roon is running well

  2. Have rebooted the Core and then I don’t see the 851N in Roon Settings -> Audio anymore

  3. Have rebooted the 851N (or changed some settings on it as I told earlier) and then the 851N re-appears in Roon Settings -> Audio

Do you want me to do this sequence ?

Are you using just Roon as the source?

851N, CXN don’t like multiple sources eg I run Roon and DLNA to my CXN , if I change between the CXN gets confused, even a change of control app causes it sometimes

A hard restart of the CXN fixes, the 851N is the same streamer unit so I assume it too will be confused

Hi @KelFab,

Yes, this is the sequence. Please note the exact local time (down to the minute) of these actions occurring and then I can enable diagnostics mode and take a look at the diagnostics from your Core.

I’m on Paris timezone based (GMT+1).
Here’s the sequence and times associated :

  1. 11h27 am : Music is playing on 851N with Roon

  2. 11h28 am : I rebooted nuc on which Roon Core server is running => this caused music to stop on 851N

  3. 11h29 am : nuc is rebooted and Roon Core server is up => on iPad Roon remote app, no more 851N Roon endpoint

  4. 11h30 am : reboot of the 851N => 851N Roon endpoint appears again on Roon app and I can instantly play music on it.

1 Like

Hi, it seems more related to the stop of the Roon Core service than a source change.

Hello @KelFab,

Thanks for letting me know those timestamps!

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Once this report has been received, I will request additional feedback from our technical team and we will reach out once again once feedback has been received. Thanks for your patience here!

so maybe you need me to do the sequence again and report the timestamps to you now that you have enabled debug mode for my account ?

Hi @KelFab,

No need for the additional timestamps. Roon logs go back quite a few days and I can confirm that your report has been received and passed on to the technical team.

Ok, great.

1 Like

Hello @KelFab,

Thanks for your patience on this, we’re working on reproducing this in the QA lab. Your logs were helpful in narrowing down our test cases. We hope to have next steps and results for you early next week.


Hello @KelFab,

We have been unable to reproduce this issue with our 851N so far.

To narrow down a possible root cause, the best next step would be for you to test restarting the Roon Core process on a different computer than you are currently using. Ideally one running Windows or macOS to rule out any distro interactions.

  • Make a Backup of your current Roon Database
  • Install the Roon app on the other PC
  • If you have an existing installation go Roon Settings -> General -> Disconnect
  • On the Choose your Core screen, select “Use this PC”
  • Deauthorize your current Core (this is reversible)
  • Verify if the same issue is occurring on the other PC


I tried with an old computer on windows 10 and it seems the problem doesn’t happen when i suddenly reboot the computer or simply kill Ronserver and related process, I’m able to come back and listen exactly where its stopped before reboot without the need of a 851N reboot or any else tweak.
So the problem may be related to Ubuntu’s Roon Core service. Can you investigate more on the Ubuntu side to see what the problem is ?

Hello @KelFab,

If you disable the UFW service on Ubunutu does the behavior with the Cambridge 851N improve?


Hello, yes it seams it has something to do with ufw.
When i look at ufw logs there’s some udp packets blocked coming from the 851N to the NUK.
But NUK ports that 851N is trying to reach are changing (1900 / 1902 / 50588 / 57444 / …).
Which range should i allow ?

Hi @KelFab,

Does this thread by any chance help with configuring the firewall?


thanks for the link but in fact it doesn’t help as l already allowed known ports on ufw :

9100:9200/tcp ALLOW
9003/udp ALLOW
1900:1902/udp ALLOW

but it seems there are more ports to allow near 50000/udp as the problem persists with only above ports open.