Connection problems with new Nucleus server

Core Machine (Operating system/System info/Roon build number)

Roon OS Version 1 (build 174)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet using Netgear Nighthawk router - Nucleus and PC connected by ethernet, Ipads by wifi
Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

SOTM SMS-200 ethernet to USB to DAC, desktop PC connected by ethernet, Ipad Pro wifi, Ipad wifi

Description Of Issue

Just got a Nucleus server - I have been using my desktop PC as Core. I decided on a new install since my library is relatively small (reloaded my files onto a local SDD installed on the nucleus). I can only connect to the Core/Nucleus using my PC - no mobile devices can see the core.

My Ipad saw the Nucleus and it said and update was needed so I let it run. It said the update was complete but still shows version 1 (build 174). I have tried updating this by reinstalling using the web interface - this is successful but still shows the same version which is NOT the current version.

I was able to format the SDD and transfer over my library from my PC. After that for some reason my Ipad was unable to connect. If I reboot Nucleus or unplug the ethernet it will see Nucleus and try to connect but then it will say “connection failed.” I have confirmed that everything is on the same network and subnet.

Knowledge base says to confirm that “accept remote connections” is checked in the general section of the settings but I don’t even see that option listed - is this because I am on an old version of the software?

I also disabled the firewall on my private network and also allowed roon access through the firewall but still I can’t connect with my Ipads. Also even though I can connect with my PC it is not recognized as an audio device.

Any suggestions would be much appreciated.


Hi Joon,

Before support jumps in to help you, I’d just like to point out that your software is in fact up to date.
The latest Roon OS version is 174, see here: Roon OS Release Notes and the latest Roon version is 401.

Is your iPad Roon version up to date? If so then I would try and close the app down completely (swipe up on the app switcher screen) and re-boot your iPad, then restart the Roon. Apologies if you have tried this already.

You could also try the “Configure Roon OS Devices” button and see if that helps.

Regarding your PC not showing up as an audio device, can you please post a screen grab of the audio tab on the Roon settings page.

You might want to check your router settings:

  • disabling a “Enable Smart Connect” setting if present and check if you can connect to the Core
  • Skim trough the settings for any IGMP Proxy-like entries, change them and check if you can connect to the Core

A reboot of the router and the Core might be needed for changes to take effect.

Hi @Joon_Rhee,

This option is only available for all-in-one Roon installs on Windows or Mac. For RoonServer (what is on the Nucleus) this is automatically enabled and not listed as an option.

Since experiencing this issue have you tried to reboot your Core machine and networking hardware?

If you connect the PC via WiFi instead of Ethernet does the same behavior occur or is it able to connect?


Thanks for the quick replies. This ruled out a software issue so it had to be something with the network (Thanks Mark). The problems are now fixed. I will explain what happened in the chance that this might benefit someone who is having similar problems.

Interestingly when my Ipad Pro could not connect I assumed all wifi devices would not connect but my wife’s Ipad connected immediately. I was even able to configure my PC as an audio device which solved that problem.

For my Ipad Pro I deleted the Roon Remote App and reinstalled and still could not see the Nucleus. The IPad is updated with the latest OS and Roon App so I was baffled why my Ipad could not see the Nucleus while my wife’s unit could. Then I looked again at Blackjack and Dylan’s comments and I rebooted my router again and suddenly it all works now.

Thanks again for the quick responses. Roon and the community are great!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.