Constant failure in connecting to Synology NAS

Hello. I am new to ROON. I want to include my Synology NAS (DS414) to my ROON Core music storage library on my macbook.
I can connect seamlessly to my NAS with my macbook via LAN, wireless as well as through browser. But when I try to connect via ROON ‘+Add Network Share’ panel, simply does not connect. I spent 2 full evening, read plenty of threads here, tried several dozens of network share location for connecting, including smb with server name as well as ip address, did not work.
also tried ftp / and other pathways without success.
username and password are all set.
typical message is: ‘unexpected error’
Can you help me with some new tips?
Thanks Zoltan

Do you have smb file sharing turned on in the Synology?

1 Like

Thanks very much for your advice. It was not turned on. I set it on as you presented, but the failure message is still keep coming: ‘could not connect to share: unauthorised’. Any idea what else could the problem be?

Try to use a backslash \ instead of /

like smb:\ \varkonyi\music

Thanks, I tried several times: ‘Host cannot be found’ was always the response. The problem could be in the NAS settings, but I cant see anything. How should I try to systematically roll up the root of the problem?

Hi @Zoltan_Varkonyi ----- Thank you for the report and sharing your feedback with us. Very appreciated!

Moving forward, just to confirm, the username and password being used when trying to mount the NAS in the application are the same used on the OS level, correct? For example, on Mac, if you go to “connect to server” and type in an IP address that is assigned to a device on your network you are prompted to login to the device (example below). The same information I would be using to access the mentioned device on the OS level would be the same information I enter in the application.

45 PM


Roon Knowledge Base: I’m having trouble setting up my NAS

Thanks Eric. It is the same I use at OS level (which works) as in the application. Zoltan

My NAS has a fix IP address in the network. Filesharing on NAS is set as it proposed on the two screenshots shared by Wizardofoz in the above thread.

Hi @Zoltan_Varkonyi ----- Thank you for the follow up and verifying that information for me. The update is very appreciated and my apologies for the delayed response.

Moving forward, I would like to recommend the following troubleshooting exercises to see if we can trigger a change in behavior with the Synology NAS. Please see below.

  • Please try setting the “maximum SMB protocol” to SMB 2.

  • I want to be be 100% certain that the NAS can be communicated with from the OS level when things are in a “fresh state”. With this in mind, I would like you to either try mounting the NAS on a device that has not been in communication with the unit previously, OR, unmount it from a current device, and try to re-add it using the same login credentials being used in Roon.