Continental Dual Mono - ASIO Support (for DSD)

Hi -

I’m trying to get DSD playback to work with my ALO Audio Continental Dual Mono device. I’ve installed the driver for my device, and I see it in the Setting as both USB2.0 High-Speed Tru HD Audio (WASAPI) device (Which does not have the choice for native DSD), and a ASIO for USB Device (ASIO) which does support native DSD. I’ve gotten the device connected to a Windows 10 laptop.

When I choose the ASIO for USB as my playback device, I cannot play anything back at all, any attempt to play any file (regardless of PCD/DSD, sample rate, etc), results in some problem that reverts Roon to saying “Choose a Zone”.

I’ve gotten native DSD to work to this device, with the same driver, via JRiver, so I know the device and driver are capable of working properly.

Anyone have any luck getting this to work?

Regards - Joe

Hello @Joseph_Moreau,

I’m would like to have the tech team take a look at your diagnostic logs in order to get a better idea of what’s happening here. Please use the directions found here and send us over a set of logs using a shared Dropbox link. Make sure to upload an archive of the “Roon” or “RoonServer” logs from your Roon Core, as well as the “RAATServer” logs from the computer that the DAC is connected to (this may be the same computer as your Roon Core).


Hi John –

After your email I wanted to try again, in order to generate fresh log entries that would be easier to find. The results of my experiments where different than before.

This time, after rebooting my laptop, I tried playing a DSF file before anything else and, magically, it worked. When I switched to a normal flac file after that, it would not play, just giving me the “Select an Audio Zone” message. Attempts to play DSF files after that would still work.

Something else I noticed, both my normal “USB 2.0” and my “ASIO” devices for the laptop disappear from the Roon Audio Settings menu after it fails to play, then after a second or two, it automatically reselects the zone.

As I experiment this afternoon, I seem to always be able to get Roon to play a DSF file to the device, but I can never get it to play a flac file, regardless of the bit rate.

All of these trials where using the ASIO driver for the device. With the WASAPI driver, I can play flac just fine, but don’t have the choice to try native dsf.

Some other notes:
Roon Client – Cthulhu (Windows 10 64 bit Laptop)
Roon Server – Ungoliant (Windows 10 64 bit)
My DAC is a Continental Dual Mono.

Here is the link for all the logs.

Thanks for support an already excellent product.

Regards - Joe

Hello @Joseph_Moreau,

Thank you for your patience while we continue investigate this issue. The tech team took a look at your logs and noticed that the client RAATServer appears to be consistently crashing when calling the “calling start()” method to initiate native DSD playback. While this nearly always indicates a failure at the driver level, we’re going to investigate what could cause playback to work with other applications to see if we can figure out what is occurring here.