Control4 - "Zone is not available error"

When selecting any of the 6 zones on any of the Control4 Navigators (app and C4 touchscreen) I get the error “Zone is not available”
This was working without issue last week. I powercycled the Nucleus, BlueOS NAD CI 580 V2’s and the C4 processor - issue remains.

The Status of the Nucleus in Control4 is “Ready”
Both music players show a connection to the Nucleus.
All Roon Player’s show Status “Waiting for Zone”

Roon Player’s Local Audio output connection to the Roon Zone’s
Roon Zone’s Local Audio output to the Zektor AUD1600 input

Roon Core Machine

Nucleus

Networking Gear & Setup Details

Ubiquiti network switches, USG router and UniFi Wi-Fi APs

Connected Audio Devices

Nucleus connected to the network. 2 BlueOS NAD music players connected to the network.
BlueOS NADs connected via RCA to audio Matrix

Number of Tracks in Library

Alot. I am not sure.

Description of Issue

When selecting any of the 6 zones on any of the Control4 Navigators (app and C4 touchscreen) I get the error “Zone is not available”
This was working without issue last week. I powercycled the Nucleus, BlueOS NAD CI 580 V2’s and the C4 processor - issue remains.

The Status of the Nucleus in Control4 is “Ready”
Both music players show a connection to the Nucleus.
All Roon Player’s show Status “Waiting for Zone”

Roon Player’s Local Audio output connection to the Roon Zone’s
Roon Zone’s Local Audio output to the Zektor AUD1600 input

Hi @Blair_Shore ,

Thanks for your patience while your case reached my queue. Can you please confirm what the Core and Zone drivers are showing in Composer? Can you please send some screenshots? Have you made any recent changes to the network setup from when it was working vs when it is not? Is there any change in behavior if you make a backup of your Control4 program and re-load the modules?

No changes were made to the Control4 database. The installation technicians updated the Control4 database and all was working until recently. I have not reloaded the modules as nothing was changed, nor did I want to temporarily solve the issue just to have it return later.
I have attached screenshots of the Control4 setup.




It’s been over a week with no reply.
This support structure sucks!!!

Hi @Blair_Shore ,

Thank you for that screenshot and for your patience here. We’ve been working on a new release which was just published yesterday, and we are catching up on the queue following this release. I’m looking over your screenshots here and I see two issues:

  1. It looks like there is no zone currently selected in this screenshot:
  1. According to your properties, your Nucleus is running an older build from July (build 998). It is important to always have the latest Roon updates so that the Roon Core can properly communicate with the Roon API.

I suggest that we proceed as follows:

  • Update Roon by opening a Roon Remote (PC, iPhone, iPad) and navigate to Roon Settings → About. There you should see the option to update and install the latest version.

  • In Composer, in the Roon Player 1/2/3/4, ensure that the proper zones are set. These same zones should be visible from within the Roon app when using a regular Roon Remote.

I can’t say for sure why it suddenly stopped working after the Control4 database update, but it’s possible that the database update reverted the Zone settings. I hope this helps!

  1. Where should it be pulling zone information from?
  2. I can update this when I am onsite next.

To be clear, when i said the Control4 database was updated, I mean the technicians added and configured all the driver in Composer to setup the Roon/Control4 integration. No firmware updates were performed between the time the integration was working and when it stopped working.

Does the Roon app or software only connect to the system locally? Is there no option of remote connection?

Hi @Blair_Shore ,

It should be pulling the Roon zone info from the Roon App, through the Roon API. If you click on the Zone dropdown, you should be able to select the currently activated zone from Roon through that menu, for example:

Did they also select the proper zones from the dropdown list I mentioned above? It seems like this is the last remaining step which may have been missed.

The Roon app only works on local WiFi at the moment. We have remote access planned on the roadmap, but I cannot comment on when it will be released.

There is no zones to select from the drop down list.
Can someone reply to my emails as well?
I am here onsite and require assistance.

Hi @Blair_Shore ,

I’m not seeing any new emails from you, I already replied to your previous one.

Do you have the zones enabled inside the Roon app? You would need to have them enabled in Roon App first and then I would restart Composer or refresh the project to pull in the new zone data. If that doesn’t help them show up, please reboot Nucleus and C4 processor as well.