Core PC does not stay awake during playback (Windows 10)

Core Machine (Operating system/System info/Roon build number)

Windows 10 (Updated) / Roon Core running on small mobile PC (Intel Atom x7-Z8750 processor), music stored on Micro SDXC / 1.7 (build 528).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi over Netgear R7000

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

KEF LSX, B&O M3, both on Airplay 2

Description Of Issue

I have a sleep timer (using the Windows 10 Power & Sleep settings) on the PC running Roon Core to ensure it goes to sleep after a certain time of inactivity. However, even when Roon is playing to one of my audio end-points, the PC still goes into sleep mode, stopping playback. From other threads I understand this is not intended behavior. Is there anything I can do to prevent the PC running core going into sleep mode when playing? Of course I would like to keep the energy saving settings so the PC does go into sleep mode when nothing has been playing for a while.

Hi @dailymango,

To clarify, are you using the Roon UI on the machine or are you using RoonServer?

Hi Dylan,
Thanks for responding to this issue. I’m using the UI on this machine.

Thanks, @dailymango.

You might have better results using RoonServer instead of the all-in-one install if you’re using other remotes. Otherwise there should be settings within Windows 10 that allow you to set exceptions for power-saving options for certain applications. Feel free to share some screenshots of your sleep/power-saving settings if you have trouble!

I really like to be able to turn the device on when I need it and have it in sleep mode when not in use (and control Roon via the UI), but I am using remotes as well, for example in the kitchen. I assume you’re referring in your advice more to the general Roon philosophy than to this specific issue? In any case, everything works fine if I set the sleep timer to 3 hours, at least it continues playing for most of the time, while still going into sleep mode when I forget to turn it off. Can you share where these application specific settings can be made, I would really like to get this to work better? Thanks @dylan!

Please let me know if you need more information to support.

Hi @dailymango,

Can you share some screenshots of your current power saving / sleep settings?

Unfortunately Roon can’t be force the computer to stay awake, but you should be able to adjust the settings in Windows so they work for you.


Hey @dylan,

Thanks, in that case I think there’s no perfect solution. I either pick a high sleep timer or none like I have right now. Please see screenshot attached

Hi @dailymango,

Yes, you’ll want to make sure that your PC is not set to sleep while Roon might be running. The settings in Power & Sleep (there are also some advanced settings with more options) should allow you to create a plan that works for you.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.