CPU high usage on Windows using 'Remote Control' mode

Hi @support,

I run my Roon Server on Linux headless machine, and on my Windows laptop (Dell XPS-15) I’m running the Windows 64bit version of the Roon software in ‘Remote Control mode’.
When I start Roon on my laptop, the laptop almost immediately starts to spin the fan so I’m getting quite a bit of noise. Looking at CPU/GPU usage I don’t notice anyting really out of ordinary, but there must be something going on as the laptop fan just keeps going on high RPM until I close the Roon app. It does not matter if Roon is active or not, the fan runs until I close it.

Now the real fun bit. I’ve downloaded Android emulator (BlueStacks) and installed the Roon android version for tablets. So the functionality is exactly the same as the native windows app (except access to the laptops output which I don’t use anyway). In this mode, the laptop fan does not get into high RPM mode.

I think you got something wrong on the Windows version as it’s quite improbable that a Android emulator with Roon would run with less CPU/GPU/etc usage as a native Windows app.

For the moment I’m forced to use this Emulator + Roon for android option as it doesn’t not trigger my laptop to run it’s fan so fast.

Please check and fix the Windows version for the Remote Control option.


I seem to recall this could be intel 4000 graphics issue or try the 32bit roon install.

support might chime in

1 Like

Thanks for the tip, I’ve tested now the 32bit version and it does seem to behave a bit better. However the fan still starts to go into high RPM mode after couple minutes of runtime.
With the Roon running in the Android Emulator my laptop stays nice and quiet.

Hi @StefanK ------ Thank you for the report and sharing this observation you have made with us. The insight is appreciated!

I would like to get our techs some more information about this behavior you are experiencing with the mentioned Win10 remote by enabling diagnostics on your account. However, before I enable may I very kindly ask you to please provide the following:

  • Please verify where your Roon core is currently being hosted.

  • Please reproduce the issue and note the time when it occurred as well as what the CPU usage was at, at the time.

Looking forward to your feedback!

Hi @Eric,

I now had a bit more time ti check what exactly is going on. I turns out my laptop is switching to the Nvidia GTX1050 when Roon is started. This then immediately increases the temperature on the GPU and the fan kicks in.
So the real issue is not on CPU but GPU.
I’ve forced the Roon windows app to run on the integrated Intel HD Graphics 630 (using the Nvidia control panel) and now the fan stays quiet.
So for me the problem is solved.
Not sure if you can do something on your side to force using the integrated graphics card instead of the dedicated GPU on laptops which have two. Would be great so that users would not do this change manually.

If you would like to enable the diagnostics, sure you can.

Roon core runs on my NAS, but the fan speed issue happens immediately even when not using Roon and keeping it in background. So I don’t think it is related to the connection with Roon core.