CPU spikes every 30 seconds

I have various combinations of Roon, Roon Server and Core running on Macs. I’ve noticed that the CPU consumption spikes just about every 30 seconds in all instances. Depending on the power of the Mac, this is anywhere between 40 to 150%. The spike only last for a couple of seconds, but is worrying nonetheless, because it happens when I’m not doing anything in Roon, anywhere. Is this considered normal behaviour?

Hello @Stephen_Dawson,

Thanks for contacting us regarding this issue, I have a few questions:

  • Does this happen on all the machines?
  • Can you please post a screenshot of the CPU usage?
  • Are you importing new files in Roon?
  • Is the activity spinner in the top-righthand corner active?
  • What is your media storage location? Is it on a NAS?

Please let me know.


Yes, it happens on all machines. Attached are Activity Monitor screenshots taken from a Mac Mini running High Sierra and Roon Server. The spike happens, as far as I can see, every 30 seconds. No files are importing, and no spinner. Media is on a Synology NAS. Same happens on an iMac running Mojave and full Roon, and a MacBook Air running High Sierra and Bridge.

Hey @Stephen_Dawson,

Thanks for sharing that screenshot. The only common factor between these machines I’m guessing is that they all have the Synology NAS as a watched folder and are all on the same network. Let’s try to eliminate one of these variables: Can you temporarily disable the Synology NAS as a watched location and let me know if the same behavior still occurs?


Sorry for the delayed reply. How do I temporarily disable the NAS watched folders without disrupting my library, edits etc. Do I just disable them in Storage Settings using the 3-dot menu? And then reenable them after the test? Just wanted to make sure this won’t upset anything I’ve done in my library.

Hello @Stephen_Dawson,

Yes, you would just need to click the 3-dot drop down menu and then press disable like so:

I would also perform a Database Backup if you want to be sure that everything stays intact but disabling and then re-enabling should not upset anything in your library, though just to be safe you can make a backup first.


OK, I tried that but it made no difference. Both Roonserver on the Mini and Roon on the iMac spiked every 30 seconds. Have you verified that this doesn’t happen on your setups?

Is this causing any performance issues, or problems using Roon? Or are you just interested in understanding why you’re seeing this in activity monitor? It’s fine either way, just want to make sure we understand what you’re seeing.

Roon is always working in the background, downloading metadata updates, analyzing audio, checking for updates, scanning storage, etc, so there’s no reason to expect it to be fully idle when you’re not listening to music.

It’s not causing any issues as such, just something I’ve noticed. But I doubt it’s any of the things you mentioned, because it happens just about exactly every 30 seconds, on all versions of Roon that I run. Seems excessive for something that should be basically idle. Be nice to know this happens to everyone, or find a reason for it.

I’ve had a similar problem, Mac OS 10.14.2 running just client and server running on Linux RoonServer.

Particularly the Mac CPU usage by Roon was simply excessive. I would often close it and use my iPad.

I read about IGMP Snooping - found it off by default on my switch, enabled it and CPU usage has dropped significantly on Mac and the occasional disconnect on the iPad has not occurred since either.

May be related and is easy (usually) to enable/disable to test.

IGMP Snooping allows the switch to listen to and make efficient decisions regarding multicast traffic. It’s not always a good thing but in smaller, home environments, it usually won’t hurt one bit and can help in the case of Roon.

Thanks for the thought. Unfortunately, all my switches are unmanaged. No idea whether snooping would enabled by default.

Might be worth looking at your router for the same thing.

No luck there either, unfortunately (Amplifi router).

Any further thoughts on this? I’ve done a bit more testing:

Shut down Roon server, and Roon on iMac doesn’t spike every 30 seconds.
Start up server, and server and Roon client start spiking.
They both spike at exactly the same time.
The CPU usage on the iMac was running at 4-9% between the spikes, even when server wasn’t running, which seems excessive in itself.
After I shut down and restarted Roon on the iMac, it usually now runs at less then 1% between the spikes.
Something strange is going on!

Out of interest, 1.6 exhibits the same behaviour.

Hi @Stephen_Dawson,

Thanks for letting us know that it is still occurring in Roon 1.6 and apologies for the delay in getting back to you here. Can you please post a screenshot of your Roon Settings -> Storage tab? I’m wondering if this could be media related.

Also, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Can you let me know the exact local time in your country (ex: 10:34PM) when these spikes occur again? I’ll check to see if there was anything strange going on in Roon at the time.


Screenshot attached. Have you checked any of your systems to see if there are any spikes? I think it would be easy to miss, especially on faster machines. Much more noticeable on a 12” Macbook or older Mac Mini.

Since it seems to happen at exactly 30 second intervals, you can pick any time you like!

Hello @Stephen_Dawson
Thanks for letting me know that information. In the diagnostics I’m seeing a lot of mounting/unmounting of a a Time Machine share:
/Volumes/com.apple.TimeMachine.localsnapshots/Backups.backupdb/Server/2019-01-29-093001/Macintosh HD

Do you have Time Machine configured as a backup or storage location on your Core? I’m wondering if this could be a cause for the spikes, does anything change if you temporarily disable Time Machine on Roon?


Sorry for the delay. My external Time Machine USB backup drive is not configured anywhere in Roon. I disabled Time Machine backups, and restarted Roon Server on my Mac Mini at 11.41am on Feb 2 local time. At 11.44 it had finished scanning. The spikes still happen.

Have you had a good look at your own instances of Roon? I use the CPU tab on Activity Monitor, with “Roon” in the search field. I’d be interested to hear what you see every 30 seconds or so.

Thanks for the continued support…

Check your /etc/fstab file. I mounted a Windows share temporarily on my RoonServer (running AudioLinux) and then removed it from the GUI when I was done with it, but it remained in my fstab file and continued to be mounted whenever Roon was running. This was with 1.5 but I doubt this behavior has changed.

Just a thought…