Crashes on iOS while tinkering

I’m still in the trial period myself (for another day or two). I too had some fairly frequent crashes in the iOS app at one point. I didn’t notice any particular pattern, but I had been doing a lot of tinkering. I had Roon running on a Macbook with Tidal integration and a Focal Arche connected to the Mac via USB. And then I was trying to stream Tidal music with the Roon app to my iPhone 11 Pro with and without a DragonFly Cobalt and/or controlling what was playing on my Arche. I think one of the iOS updates in the middle of all this and I’ve since moved Roon to an Ubuntu VM and my Arche to an Allo USBridge. The Mac is only used for control now. The Roon client on iOS has been stable since, although I haven’t tried the Dragonfly Cobalt in a while. My work-around was just to run the Tidal app on iOS instead of streaming through Roon, which was no big deal. But when I get my library into Roon that’ll be a bigger problem.

Hello @madtrader, thanks for the information. Could you please respond here with what time this happens (your local time) next time it does? I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Also, does this issue seem to happen on a particular screen of the app? Do you have this issue on any other remotes?

Will do. I’ll try using it more again to see if I can trigger it. My 14 day trial just ended today and I got the charge, so I’m committed for a year now :slight_smile: . I’ve not been using my iPhone as much lately as I’ve been working on “perfecting” my Allo USBridge setup and using my Macbook as the control (as it’s conveniently sitting next to it at the moment). When those crashes were happening, it seemed to be at random, although at one point that meant I couldn’t even restart it. That is it would crash back to the home screen, I’d touch the Roon icon and it’d load, but within less than a second (about the time for me to perceive the app was up and drawing) it’d crash again.

I’m also having issues with iOS crashes, I have posted separately but will be following this thread.

A post was split to a new topic: Crashes Browsing TIDAL

An update from my further testing. I’ve been trying to use my iPhone 11 Pro with Dragonfly Cobalt as an endpoint over the weekend (at night after the family is asleep, while reading). It’s gone pretty well. Not perfect, but pretty well.

Working backward from memory – last night I got some audio dropouts. I have yet to import any of my own files, so Tidal is my source for Roon at the moment. I realize that that adds a potential failure point and so dropouts could be in the stream from Tidal or the stream to my iPhone or more. I don’t consider this a Roon problem, but I thought I’d note it since we’re looking at the iOS stability. Especially as I read Roon has generous buffering to try to overcome connectivity issues.

The previous night (Saturday night) went just fine. I don’t recall any issues.

The previous night to that (Friday night), I had a crash I think. I had some odd UI behavior where I’d wake up the phone and Roon was in the foreground, but the UI was unresponsive. Almost like when you have dry hands and a touch screen stops working. Except I could use the iOS gestures to exit and whatnot. Music continued to play through most of these. I did have one (I’m going to say it was around 23:00 CDT Friday night) where this happened and the UI never returned. I exited Roon and the music continued to play for a couple seconds and then that died. Starting Roon again loaded and then I had to restart playing. It was just a bit glitchy that night.

One other thing to note is just how fast it drains battery life. Maybe this is expected. As I mentioned above, I’m using an iPhone 11 Pro. I also have the official Apple battery case. Despite the extra bulk, I love the combined battery life. I have been known to go 4 to 5 days without having to find a charger. It’s regularly 3 to 4 days, but this weekend I’ve had to charge my phone twice.

Will continue to focus on this testing. I’m planning on getting some of my own CD rips into the library this week once I decide how I want to do it.

Using a little DAC like the Cobalt that draws its power from the phone will drastically reduce battery life. So much so, that I just gave up using it as it wasn’t worth the recharge hassle and attached it to a PC instead. You might look into DACs which are powered by their own battery so you are not using up your phone’s charge; Chord Mojo comes to mind.

Thanks. I will look into giving that a try. I’ve been curious how a Mojo sounds and they’re not too expensive. I bought the Cobalt just to see as well. I should have given the Mojo a try at CanJam NYC. I am a neophyte in this and the first I’d heard of Chord was at the show. I sat down at their booth and listened to their Hugo 2 and their new streamer bits they apparently released at the show, but didn’t give the Mojo or Dave a try. Had I known…

My headphone station at my desk here is an Allo USBridge Siganture + Digione Signature tied to a Focal Arche via Coax. I’ve got some time between meetings, so I’ll fire that up and try using the iOS app for control to continue stability testing. I’ve been using my Macbook for control as it’s sitting right there next to it, but I’ll switch to get more iOS time.

Next update: I spent hours yesterday controlling my USBridge from my iPhone and it worked swimmingly. Then last night, I setup again with my Cobalt connected to my iPhone. It was a disaster. This was about 22:45 CDT. I pulled up the Norah Jones “Come Away With Me” album from Tidal (again everything is coming from Tidal for me currently, local files not loaded into Roon yet). I couldn’t get through a track. I stopped counting at 6 crashes, but it was likely over 2 dozen. I pushed through 2 tracks before I gave up and switched to the Tidal app and things were perfect for the rest of the night.

Hello @madtrader,

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Another daily update: there were some updates for my Linux box hosting Roon (including the kernel), so I applied those yesterday and rebooted. I actually rebooted twice as I needed to apply updates to the hypervisor host as well (different OS entirely). I setup again with my Dragonfly Cobalt on my iPhone last night and had some initial troubles a little before 22:00 CDT. I think it actually crashed on me once or twice. I had the odd situation where I went to switch zones to the phone and it wasn’t there. After a crash/restart it was. And then I was able to play/browse/queue just fine for the rest of the night.

Next daily update: I guess there was a new version of Roon released both on the iPhone and Core, so I updated both. I used my iPhone to control my Allo endpoint again yesterday during the day. No problems. I switched to the iPhone-Cobalt combo again last night and in terms of playback and crashes it was fine, but I encountered a new problem. I had been listening a while and used the menu to go to “Albums” and it showed me a dialog “Try removing some Focus criteria”. I don’t know what that means. I didn’t select any filters. I worked around it by using the Artists and Tracks path through the main menu and that worked for a while. And then they too started showing that dialog. Not quite sure what to do about that.

Hey @madtrader, thanks for all this detail! I’ve submitted this information to our team for a closer review. In the meantime, I wanted to confirm a few details about your setup so I can be precise for the development team:

  1. Your core runs Linux and is on the latest version of Roon? (build 537) which you can check under “Settings>About”
  2. iPhone Pro is also on the latest version of Roon
  3. What router do you use? As well as network details/devices in use

Hi @nuwriy, let me use the same # order for answers:

  1. Yes, Linux, Ubuntu 20.04 LTS. I don’t recall what version/build of Roon was installed before the update I mentioned in my post yesterday, but when I updated it was to 536. I see now it’s telling me there is an update available and I will update after posting this.
  2. My iPhone is running build 536 as well. I do a daily app store check for all updates and Roon wasn’t updated this morning, so I presume it’s the latest released. As I put in my last update there was an update before.
  3. My network and router isn’t too crazy, but it’s not typical equipment. I run a FreeBSD based firewall and router, with three wired networks (the firewall being the convergence point). My wireless is tied to one of the wired networks and is all Ubiquiti Unifi equipment. The access points are 2x UAP-AC-HD (both wired) and a UAP-AC-M mesh that uplinks to the other APs depending one which is up or down. The mesh node basically never has clients, though. The Linux host for Roon core is a virtual machine on another FreeBSD server. It has multiple wired network interfaces. The Linux VM is configured with a virtio network adapter configured into a virtual switch that is bridged into one network interface while the FreeBSD host uses the other for its own communication. Both interfaces are completely open to the wireless network. There’s no filtering being done between those wired and wireless networks. They’re bridged at layer 2 and I can see the mac addresses from both networks with an arp table lookup from any device on either of those networks. On the other side of my firewall, I have fiber to the home and I’m paying for a 300mbps down, 30mbps up connection.

And as an update on the daily activity, I setup again with the iPhone and Cobalt last night. It mostly worked. I did have it “lose” the Cobalt a couple times again where I was still hooked up, but audio came out of the phone speakers instead of the headphones. These were occasions where I was streaming and it just stopped for some reason. I woke up the phone and it showed the play arrow as if there had been a phantom pause pushed. I hit play and wondered why the music was so faint, quickly realizing it was beause it wasn’t coming out of my headphones. One time it worked again for no apparent reason. Another time I had to unplug everything and individually replug again (first the USB dongle adapter into the phone, then the Cobalt into the adapter, then the headphones into the Cobalt). The good news is that the weird “Try removing some Focus criteria” message never appeared and I as able to navigate and play as expected.

Another update: So Friday night, I updated the iOS app on my phone to 537. I had had more problems with the Cobalt music seemed to randomly skip to the next track. I’d be playing fine and then boom, suddenly the next track would play. Also it’d occasionally just stop. And then there was it losing the local zone again too. I even had it stop playing, I go unlock the phone and hit play and it come out of the speakers instead of the Cobalt. Very frustrating. I eventually switched to streaming Tidal in it’s own app and it was completely perfect for the rest of the night.

So Saturday I had a mission to get my local files into Roon to rule out if my problems are Tidal related. Well that took longer than I expected. I actually broke a ton of stuff along the way (which lead to rebooting the VM host that the Roon VM lives on more than once), but Sunday I finally got it. I got my iTunes library copied over to my virtual machine host, spun up a jail to run Samba, and got it functioning serving up my iTunes library over CIFS so that Roon could see it. I was a little surprised at how long it took to process/scan. It wasn’t crazy slow, just slower than I expected (like my library was larger than expected). I proceed to stream a bit to an AppleTV in the living room and it seemed to work. Then last night I setup again with my iPhone and the Cobalt. Even using just the local files, I had several issues with music skipping to the next track randomly or stopping entirely. Maybe I had one case of having to disconnect the Cobalt and reset (I sorta forget, it was late). Frustrating. I’m hoping to get some time streaming on my USBridge + Arche setup today, but I have too many meetings for it to be for very long.

Small update. I didn’t get to do any listening last night, but I did do some yesterday afternoon and this afternoon on my USBridge + Arche setup. I used the iOS app on my iPhone for control and playback has been flawless. The only hiccup is that when I started the Roon app on my iPhone yesterday it came up with no zone selected. When I hit the switch zones button the phone itself wasn’t listed as a zone. I picked the USBridge and went on my way, but another case of the iOS private zone disappearing.

Hello @madtrader, I passed this information along to our team and they were wondering if you’re using the USB 2.0 or 3.0 CCK.

I believe I have the USB 3.0 CCK. I just checked my receipt from Apple and they call it the “Lightning to USB 3 Camera Adapter” (ordered March 17 of this year). It’s very hard to read, but the model printed on it is A1619.

Since I’m here, the update is I haven’t been streaming at night so much, but I did last night, again with the Cobalt. This time with purchased hi-res files (not from Tidal). I experienced that same sort of skipping where suddenly it would advance tracks. One new thing was the occasional pause during a track. It wasn’t consistent, but it was there. It’d pause for a second or three. I was thinking it may advance to the next track and then it’d pick back up again. I played some of those same hi-res files through my Allo + Arche earlier in the day without a hitch. Unfortunately I’ve been on the phone most of the day today, so no music at all.

Small update: I haven’t had much time to listen lately. I did get an hour or so in yesterday and I used my iPhone as a control for the Allo + Focal zone. Roon on the iPhone hung at one point – the UI wouldn’t respond to any touch. I’d woken up the iPhone to hit the pause/play button (I forget which it was) and it wouldn’t respond to anything. I closed the app (not, kill, just the swipe up from the bottom to go to the home screen) and then touched the Roon icon again. It was unresponsive for a second and then crashed back to the home screen. I then launched Roon again and things worked as expected.

Hello @madtrader, I ran what we have so far by the team and they asked that I get some additional logs from you.

This time, can you note the exact local time + date when this issue next occurs and manually send me a copy of your Roon Logs by using these instructions? The best way to get them over to me would be via this link.