Created new backup but Objects folder is missing

I’m referencing to this post from Carl, one of the support moderators:


I deleted my Roon backup, deleting it within the File Manager, and started over. (My reason for doing so is discussed in #3 below.)

The new backup folder is smaller in size, and it contains only a folder called “Roon Backups.” Inside that folder is a folder called “37b9752f-a25e-4755-1f18-a101aeb48e48” and inside that folder are a large number of smaller numerical folders. That folder is 2 GB in size, for 3,100 albums and 48,000 tracks. I believe the original backup was significantly larger, and also took quite a while to create. The new backup took only 5 to 10 minutes to create.

It does NOT contain a folder called “objects.”

Since that appeared to be wrong, I deleted the backup, this time using the “delete” function within Roon. I created a new backup – with the same result. It appear to be an incremental backup, made much faster, and without an objects folder.

(1) Is it possible that I have confused Roon, and it is only making incremental backups, even though the master backup and objects folder is gone?

(2) If so, how do I correct that? How do I start over, and force Roon to create a master backup that will INCLUDE an objects folder?

(3) The Roon backup settings window also says that you should backup to multiple locations. I also tried that, and the backup on a separate drive was also in the 2 GB range, and also appeared to be smaller. It also did not have a folder called “objects.” I feared that I had created an incremental backup on a different drive, with the result that the backup data base would be really confused. That is what prompted me to so delete all of the backups and start over. That didn’t work, as described above.

How do you create two separate master backups on two drives, since you recommend doing just that? How do I create two master backups on two drives that are separate and unique, each containing an objects folder? Since that is precisely what you recommend?

Many thanks in advance for your response!


That post from @Carl dates from June 2017, and I think that there have been changes under the covers to Roon’s backup mechanisms. At any rate, I’ve just checked my backup folders, and I don’t have an objects folder in any of my backup locations.

To add a second backup location, just click the “Add” button on the Scheduled Backups screen, and tell Roon where it should put the additional backup. Here, for example, I’ve used it to create a second scheduled backup to be stored on my server called Degas, in addition to the backups stored on a USB drive attached to my Core machine (running ROCK):



Setting aside the question about the object folder, as I recall, the first backup (which I deleted) was about 1/3 larger and took well over an hour to create. As I recall it was saving some art, which took time. The replacement is smaller and took less than five to ten minutes. (The new backup is 2 GB in size, for 3,100 albums and 48,000 tracks.)

Thus my concern that I’m creating incremental backups but lack the original.

I guess one final question. Where is the data file located that tells Roon whether to add a complete backup or an incremental backup? If it is in the core database, I might have confused Roon as that file might believe the master was already done.

If the data file on backups is within the backup folder, and it is either the absence of a data file in the backup folder that tells Roon to do a master backup, or the existence of a data file in the backup folder that tells Roon to an incremental backup – then I agree, everything should be OK.

I just want to be sure that the backups I’m making are complete, and will do a complete restore, should the need arise!

Many thanks for the quick response, and to all of the moderators and the Roon team for the excellent support.

AFAIK, everything should be in the backup folder to tell Roon what’s what. You can always use the Clean/Restore function of the Backup Manager to see what Roon knows about the backups you have taken…

Hey @allan2 – there’s a quick test you can do here to be sure.

It’s not clear what platform your Core is on, but you can go in, find your Roon database, and rename it to Roon_main, or something like that.

Then just re-install Roon, and before logging in, click Restore:

Run the restore and you should be good to go – and you can always rename Roon_main back to Roon and you’re right where you started.

Hope that helps!