Current best practices for synching between locations


After reviewing pretty old threads on the topic, I ask if there is any update to the best practice for keeping two Roon locations (2 houses) in synch?

Per several posts I’ve read, I copied the Database folder from my “Master” installation of Roon, moved it to second house via DropBox, then over-wrote the Database folder at my other Roon installation manually.

This resulted in a “cannot load database” issue at second house. Did I just get unlucky with the copy and over-write or is this not the best practice to keep locations in sync?

(Sorry to say I already uninstalled and re-installed Roon on the second location so I don’t think I have log files. My question is more general about best practices. If I have the problem again I will preserve the log info).


I might be wrong but the new backup and restore feature might be the best option to get your sites synced up initially.

I didn’t notice a button to restore from backup on initial install. Perhaps I just missed it. In any case, the initial installation at the second location worked fine with simply replacing the database folder on a new install with the database from the Master installation.

But the next time I went to update the second installation with the database from the Master location, I got the cannot load database message. Perhaps it is because the storage locations are different?

It’s there, but it’s not front and center. You can also restore a backup from within Roon via Settings -> Backups.

For some reason the database you copied over is corrupt. Was Roon 100% shut down at your primary location when you made the copy?

I am pretty sure Roon was 100% shut down when I copied the DB. Is there something to do other than close the Roon window? I don’t think there is anything to shut down from the system tray…

Assuming that you’re running the regular Roon application (not RoonServer) then that should be all you need to do.

Although your method is valid I’ve started using the backup / restore functionality for these migrations and it’s worked great so far.

Thanks. I guess I will assume I just got unlucky with some corruption rather than my method does not work. I’ll try the restore backup method too.