DAC Stuck at "Fixed Volume"

Hi @support Just upgraded to 1.5 (Build 323) on iPad, Core and MBP. Roon Bridge is at Build 156 (with Ropieee load).

Since the update, I am no longer able to select “Device Volume”. If I select it, and hit OK, it will just revert back to “Fixed Volume”. Tried disabling the audio device and re-enabling to no avail.

This is a major issue as now I cannot control volume (My DAC is hidden out of sight).

DAC - Mytek Brooklyn

Previous Version - Build 320.

I was able to get it to work again, by going into the device, then clicking on “Identify this device” and selecting a random device (since the Mytek Brooklyn isn’t there, I selected an Oppo device) and then I could control volume again! I then removed the device and left it as unidentified and now it’s working again. Bizarre.

Hello @narkotic,

Thank you for the report, I will forward this information to the tech team for analysis.


Hi @john, I left something out that I just remembered (for the sake of regression testing) :slight_smile:

  1. I updated to the latest version of Roon. I do not think this is solely what broke volume.
  2. I noticed that there was an option to “select my actual DAC” to show a picture next to it in Roon. I performed a search and it only showed two for Mytek, Manhattan & Stereo 192. I have the Brooklyn. I thought, well, the Stereo 192 is close enough, and I selected it.
  3. This defaulted all options minus the volume limits I had previously set for this device.
  4. I selected all of the right options, including “device volume” and hit save.
  5. I hit play and almost blew my ears out. Hit the pause button. Blew all output fuses in my amps that are there to protect them and the 2400 watts going to my speakers. Yeah, replacing these requires me to move 200lbs of metal upside down and remove 15 screws and reach into a tiny cavern with charged capacitors holding thousands of volts (live dangerously!)
  6. I looked in settings and noticed it was set to fixed volume again, and buried in advanced options, an option for “set to max volume during playback” was selected. Great! /sarcasm
  7. De-selected this option, set “device volume” again, and it went back to fixed (but it did keep off max volume option)
  8. Tried “DSP” volume, this selected, but I could not change the slider. It showed something like -214733 as a min volume.
  9. Changing from DSP volume to device volume made it go back to DSP volume.
  10. Disabling / re-enabling device didn’t fix it
  11. Changing the device type back to unidentified didn’t fix it.
  12. Changing it to an Oppo fixed it.
  13. Changing it back to unidentified kept it fixed and reverted back to how it worked.

Hello @narkotic,

Thanks again for all of the helpful info, I can now provide some insight as to what occurred here. I’ve passed this info on to the tech team to see if there’s anything we can do better on our end of things to help people from reaching this state.

As part of the Roon 1.5 update, as you can see we’ve added a new device identification engine that not only controls the line art for the device, but actually helps users know they are choosing the best settings for their device. Sine the Mytek Stereo 192 DSD-DAC does not have USB Volume control capabilities, we default the “Volume Control” setting to “Fixed Volume” and then remove the option for “Device Volume” to help remove confusion for users.

If this state ever happens again with this device or another, the best way to rectify it is to unidentify the device, then click the “Load Defaults” button and save. This should revert the device to the settings that Roon detects through the USB information we are receiving.


Thanks John. I did try that and it didn’t seem to work. It wasn’t until I selected a different manufacturer device until I was able to get “Device Volume” to operate again.

Also - it did not remove the option for Device Volume when the Stereo 192 was selected. It allowed it to be selected yet it did not remain set.

Instead of creating a separate post, hope you don’t mind me attaching to this one. I had a similar issue with my Goldmund Satya speakers playing wirelessly: since updating to 1.5, I could not get the output device (a Goldmund USB dongle that is inserted in the Nucleus and transfers the music to the speakers wirelessly) on “Device Volume”, instead, it remained on “DSP Volume” even after saving it as “Device Volume”. This caused some headaches with the signal dropping out. After finding this post, I “identified” the USB dongle as an Apple AirPlay device, saved its volume control to “Device Volume”, then went back and unidentified the device, after which the “Device Volume” remained active. So all is well now, but it was a similar experience, so I thought it’d be useful to add.


Do you know if usb dongle can stream 24bit music?

@moderators This will be better served in a #support post and you should remove this post and start a new post under support with the requested information

Welcome to the community.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.