dCS Bartok not decoding MQA with USB input

Core Machine (Operating system/System info/Roon build number)

NUC ROCK

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet in house

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

dCS Bartok

Description Of Issue

I sent the same inquiry to dCS but hopefully Roon staff may also have an answer. In my current setting, Bartok can properly process MQA files with the network input but not with the USB input (dCS setting of USB class 2 is chosen).

Below are the two screen captures. First is the proper function with the network connection (Bartok as Roon endpoint), and the second is using the USB output of Mac running as Roon remote. MQA files are properly authenticated in both, but only the network connection setting can decode the MQA files, while the USB connection plays them as 24/48 without decoding. On the other hand, I just checked and Bartok works as a “renderer only”, if I turn on the core unfolding.

What am I doing wrong?


Hi Andrew.

I don’t have a DCS transport/DAC, but I am slightly puzzled by your analysis of the above signal path displays.

The second signal path reflects exactly what I see when I stream MQA content (unprocessed by Roon and bit-perfect) to my Sonore microRendu renderer connected via USB to my Mytek Brooklyn DAC+.

The display on my Mytek DAC (blue or green LED depending upon the level of MQA authentication in the streamed file) indicates that it is receiving a bit-perfect stream and is successfully (fully) decoding the MQA content.

What is it about the signal path you have included above that makes you believe you have a problem with the DCS DAC over USB?

My interpretation (which may be wrong) is that the first signal path (including the word ‘Enhanced’) is indicating that in this case MQA decoding is being carried out by Roon, and an ‘enhanced’ data stream is being fed to your Bartok. The second signal path indicates that a bit-perfect (lossless) stream is being passed to your Bartok, requiring the Bartok to carry out the MQA decoding.

Actually, the first signal path means that Roon authenticates the MQA stream. Roon does not perform MQA decoding here. Via RAAT it sends the bitperfect bitstream to Bartok, which carries out MQA Full Decoding, which is considered to be Enhanced. Roon knows about this because this information is fed back to Roon via RAAT.

The second signal path means Roon sends lossless bitstream to the DAC via USB, which can do whatever processing including MQA Full Decoding in the example here, but Roon does not know what happens in the hardware beyond USB so it is not shown in the signal path.

MQA certified DAC must have an indication (a light or text display) to signal an authenticated MQA stream. If it has the signal, you’re assured your DAC is carrying out MQA decoding.

@wklie Thanks for the clarification. What you said is exactly right, and I know that Bartok is not decoding because the display shows that it’s no MQA and playing at 24/48. I’m beginning to wonder if the original design is that way. The manual vaguely indicated that MQA decoding is done with network and USB2 (USB A) inputs, but there is no clear mention that USB1 (USB B) is MQA capable. It looks like something that dCS will be able to answer. I will keep you posted if I get a response from dCS.

Before you get an official response, I have this suggestion. For USB, please enable Roon MQA Core Decoder, and set MQA Capabliities to “Renderer Only”. See if you get the MQA authentication light / text this way.

Thank you Peter.

Does this mean that there is a setting in Roon to instruct Roon to authenticate but not process MQA streams? I am already aware that Roon can be configured to decode or pass through bit perfect MQA streams to each individual device connected to the network.

I ask this, because in my own case:

  1. Sonore microRendu/Mytek Brooklyn+ : The signal path from Roon is labelled as ‘Lossless’, but Roon passes through a bit-perfect file which is successfully decoded by my DAC as indicated by the blue/green light displayed on the DAC.

  2. Linn Klimax DS/1: The signal path from Roon is defined as lossless, but Roon performs the first MQA unfold and passes a hi-res PCM stream to my Linn streaming DAC.

The reference to an ‘enhanced’ signal path indicates either that some DSP processing (excluding the first MQA unfold) is taking place in Roon, or that Roon is authenticating the MQA source, and not that Roon is actually performing the unfold.

Is this correct?

I edited that part in the original posting. Maybe you missed it. Bartok cannot work even as a “renderer only” when using the USB1 input.

Sort of. It authenticates but does not perform any MQA decoding if Roon knows your chain supports MQA Full Decoding, and you do not use any Roon DSP engine and volume leveling features. (There may be other scenarios too but I do not claim to know them all.)

If Roon knows MQA rendering (or Full MQA Decoding) is taking place, Roon requires this to be marked as Enhanced even if Roon itself is not doing any DSP or any MQA rendering (which Roon cannot do).

To my knowledge, the second signal path is not representing a renderer-only config.

After enabling Roon MQA Core Decoder, and setting MQA Capabliities to “Renderer Only”, we should see a Roon MQA Core decoding step in the signal path. This step is missing.

Your signal path looks like you’ve set it to Decoder+Renderer (incorrect) instead of Renderer-only.

Sorry my bad. I did the proper setting of Bartok as “renderer only” and it seems to correctly render the MQA 24/192 files. The original posting was revised accordingly.

But setting it as “decoder and renderer” and turning the core decoding on, it doesn’t do MQA at all and plays at the original 24/48. Strange.

So, in the case of my Sonore/microRendu/Mytek Brooklyn DAC+ set-up, Roon does not indicate the signal path to be ’enhanced’ because it is not aware that MQA rendering (Full MQA Decoding) is taking place in my Mytek DAC?

@hmack, I’d appreciate it if you could move your discussion as a new topic, as the two issues are not exactly related. I’d like to keep my topic and threads short. Thank you.

Right, I believe this to be the case.

Ok Andrew.

Peter has kindly answered my questions, and so I have no need to post anything more on this thread.

1 Like

To Roon support team, so I summarize my findings as follows.

Test file is MQA 24/192, folded into 24/48.
Using the USB input signal provided by a Mac Roon Remote,

  • Bartok does not work as “decoder and renderer”. Roon passes the MQA raw file but Bartok plays it as 24/48.
  • As a “decoder and renderer”, with “Enable MQA core decoding” on, it still plays it as 24/48, i.e. even the core unfolding part is ignored.
  • As a “renderer only”, with “Enable MQA core decoding” on, it properly plays MQA file at 24/192.

It appears that Bartok as a decoder and renderer is unable to see the passed-through MQA signal as MQA when USB input is used. So the solution may come from either dCS or Roon. Please look into this and come up with a fix.

I read the Bartok manual and from my understanding what you experienced is normal behavior for USB audio input. (A different scenario from USB thumb drive non-Roon file playback.) Let’s see what the official response is.

This is normal behavior for Roon, as explained in my response to @hmack. Roon is designed not to perform MQA Core decoding here in this scenario.

1 Like

Yes, that’s what I deciphered from the manual, which was vaguely written about this. So MQA is done with network and USB2 inputs, but not USB1 input. Why??

Thanks. It makes me wonder why there is the additional switch to “enable MQA core encoding” then. Why would anyone use the DAC as a renderer only, and not use core decoding?

@wklie, here is the official response from dCS. What you and I read on the manual was right, and here is a clear explanation as to why.

I must also add that dCS’s customer support has been prompt and highly professional in my experience. Just like their products.

Case closed.

1 Like

The switch should always be enabled, except for two conditions:

  1. The MQA DAC runs a very early firmware that does not support MQA Core decoded input
  2. Do not wish to use MQA

Not all MQA DAC includes MQA Core decoder in the hardware - USB audio input of your DAC and several other DACs are MQA Renderers only.

Again, “No MQA support” device setting should take care of it all. I can’t think of an occasion when the device is declared a renderer without using the core decoding. But I realize I’m nitpicking…