Demon AVR X2300W DNLA support?

Hi all, I am brand new to this so please forgive my ignorance!
I have just subscribed to Tidal and am trialling Roon. With Tidal, I am on the £19.99 HiFi subscription.
Going directly through Tidal, I can access and successfully play Tidal Masters in all their Hi Def glory from my laptop to the Denon amp via HDMI.
However, through Roon, both wired and wireless, the denon is changing to Airplay with the resulting downmix/downgrade in sound! When I have previously streamed to the Denon via DLNA, it supports Hi Res files including DSD.
My question is, is there any way, either wired or wireless, to get Roon to stream to my amp unaltered Tidal Hi Res Masters files, or will it always down-convert? If the latter, I don’t really see the advantage of Roon, as sound quality is paramount to me.
Under Audio it shows "Networked - Airplay to my Sky Q box, Apple TV3 and Denon Avr X2300W.
I have Roon V1.5 (build 334) stable 64bit.
Windows 10 Home Version 1803.
HP Envy x360 with 8 GB RAM, AMD A12-9720p
64 bit OS x 64 based procesor.
Thanks for any help or advice.

Roon does not support DLNA/UPnP. For direct network streaming to a Denon AVR, you have to use AirPlay. For indirect network streaming, you have to add a Roon compatible endpoint in between.


Andrew is correct. I have the same receiver, the Denon AVR X2300W.

You will need a DAC or any other endpoint to avoid the airplay connection.
For instance a chrome cast audio will do nicely if you don’t want to spend a lot of money.

For orientation purposes, John Darko just put out a new video about Sonos connect alternatives,
Check it out:

I use the Bluesound Node 2 and it suits my needs perfectly.

Hey @Robert_McHugo — Thanks for reaching out!

Andrew and Henri’s comments above are correct — Roon is unable to play to the Denon over the network any way except for AirPlay.

Just to clarify, you should also be able to play to this device with a higher quality output than AirPlay via HDMI. Have you tried using an HDMI connection with Roon?


1 Like

Thanks for your reply Andrew, much appreciated.

Thanks for responding Henri. I have a Musical Fidelity V90 DAC stored away which I do not currently use in my set up. Would this suffice? It has an asynchronous USB connection. I’m not sure how this would be set up though. The Bluesound Node 2 sounds good but at £500 is more than I wish to spend at this current time. Would an Audioquest Dragonfly Red be okay. Again, not sure how this would fit in? Thanks.

Hi Dylan, thanks for your reply. Yes, I have tried connecting the laptop directly to the Denon via HDMI. This worked fine when using Tidal directly, but when I switched to Roon, it again switched to AirPlay, even though I was “wired” with HDMI. Is there some setting in Roon that may be making my amp default to Airplay? Thanks for any assistance.

Did you enable the HDMI connection within Roon? It should be showing as an extra audio device besides the Airplay device that you have already enabled. FWIW, I have my Roon Core connected directly to my Denon via HDMI. It works fine, and can be used to play multichannel recordings as well.

It also has the normal RCA connection. Just try it. And let your ears be the judge. if you like the result, good, use it. If you don’t like the result, try the Audioquest Dragonfly Red.

If you don’t like both, try some of the other options. In the end it’s about what you like.

Thanks for replying Geoff. No I have not enabled HDMI. I will have a look and try your suggestion. Many thanks.

Cheers Henri, I will try the V90 and see if it works.

1 Like

Hi Geoff, how do you enable HDMI? Is it in Settings, then Audio? Nothing is showing next to my Denon ( under devices located on my Network), either with HDMI plugged in or out. When I click the gear icon next to Denon and choose Device Set Up,again there is nothing pertaining to HDMI? Thanks.

Hey @Robert_McHugo,

Can you share a screenshot of what you see in Settings > Audio?

HDMI should show up under Connected to this PC. Do you see any HDMI options here?


Hey Dylan, see attached screen shots. Each time i play a track in Roon, the Denon switches itself from Aux1 on the Denon to Airplay

irplay, whether connected to HDMI or not.

@Robert_McHugo - you will need to have your Denon connected directly with your laptop via HDMI in order to get the maximum quality.

I assume that at the moment you have the Denon connected to your Apple TV device via HDMI? The problem with that is, even if you enable the Apple TV device within Roon, and use that to drive the Denon (as @trtlrock suggests), you will still be using Airplay, and hence limiting the audio quality that could be achieved by connecting the Denon directly to your laptop.

As an example, here’s some of the audio devices I see in my setup:

My Roon Core is running on an Intel NUC using Roon’s ROCK operating system. The HDMI connector is the HDA Intel PCH HDMI 0 device, and I use that to connect to one of the Denon’s HDMI inputs for my music. The Device Setup that I use within Roon is:

And the Advanced Setup screen looks like:

Hi, will that not just enable Airplay on the Apple TV and Denon? I don’t want AirPlay but higher quality and AirPlay is limited to cd quality. Thanks.

Hi Geoff. How do I connect to Roon Core direct? When I set up Roon initially, the results were as per my screen shot, ie “connected to this pc” and “Networked” as opposed to “”Connected to Core” like yours. Would I need to go through the set up process again, ie uninstall and reinstall Roon? Thanks.

Hey Dylan, further to my screenshots, under “Settings” - “Audio”, my screen is very different from Geoff_Coupe in the thread.

I have showing, “Connected to this PC” and “Networked”.

However Geoff has showing under “Audio”…“Connected to this PC” and “Connected to Core” which has the option to enable HDMI. I cannot figure out how to access “Connected to Core” which I assume would allow me to disable Airplay from the Denon and enable HDMI?

Any help or advice would be much appreciated. Thanks.

You have Roon installed on your laptop, I assume? Then that is the full version of Roon, which has all three components of Roon ( Core, Control, and Output) included. So your Core is running on your laptop.

You may not see an audio device appear in Roon until you have connected your laptop to your Denon with an HDMI cable, and turned the Denon on. If an extra device appears (i.e. in addition to the “System Output” and the “Realtek High Definition Audio”), enable that and give it a name (e.g. Denon). Otherwise, it may be that the Realtek High Definition Audio device is your HDMI port (but I think this is unlikely). In this, I am assuming that your laptop does have an HDMI port, of course…

Here’s an example of what you might expect to see. These screenshots were taken of one of my laptops that does not have an HDMI port, but which does have a USB-C port, into which a USB-C to HDMI adaptor has been plugged. The first screenshot is of the devices when I do not have anything connected to the HDMI port.

The second is what I see when I connect a monitor with built-in speakers to the HDMI port. Note how an extra device appears - this is the HDMI channel. Enabling this in Roon would enable me to play music through the monitor speakers.

Provided you can connect your Denon directly to your laptop using an HDMI cable, I would expect you to see something similar to this.

1 Like