DEQX HDP5 gives error "Transport: Failed to open the device" [Resolved - USB type A to type B cable between the USB input card at the back of the DEQx and the bank of USB inputs under the power supply]


i am having a problem with Roon connecting to my DEQX HDP5.

when i tried to play to the DEQX on my MacBook pro, Roon gave the message: “Transport: Failed to open the device”

It is frustrating because I can see the track information on the screen of the DEQX! Is this something to do with using a mac?

I didn’t even think DEQX products were RoonReady yet. From everything I’ve read online, it’s still “coming soon”.


There are several things you can do which may give you a connection, some, you may already have tried. Also you do not say how you are connecting, USB? LAN?

  1. Re-boot everything but leave the DEQX to last when the Mac has booted up.
  2. If using USB you might try another cable, I have never found the DEQX to be as fussy as some DACs out there but it may be worth a try. Power off with the rear button, wait 30 secs and try again.
  3. If using the LAN select an Analogue output and the select Auto on the remote or Internal on the front panel of the DEQX. Again cycle the power.

Report back with your success or failure…


1 Like

Hi @Henry_Mancini ----- Thank you for the report and my apologies for the troubles here. I would highly recommend trying the troubleshooting tips offered by Steven (@The_Listener) :microscope:

Furthermore, a description of your setup as seen here along with screenshots of your audio settings in Roon would greatly aide in helping to evaluate the problem here.



I tried to send you emails with the information you requested but I received many error messages so I am going to copy them here.

Steven’s advice did not work.
Roon version 1.2
Build 165
Stable 64 bit
Mac OS X 10.12.2
MacBook Pro retina 15 inch mid 2014

Music is on a MacBook Pro hard drive
15000 tracks

Whenever I click play on the DEQX playback device I receive error message
“Transport: failed to open the audio device”

Netgear Orbi router
Is there any other networking hardware involved? No
Is everything wired, wireless, or is there a mix of wired and wireless gear? Wired

Issue occurs when I play music from both Tidal and my hard drive
With all files that I ripped myself.
Mu Tidal account is from the USA.

What output are you using?
Screenshots to follow

Are you using anything else in your chain (such as DIRAC, Amarra sQ, etc.) No
Does this issue happen with different kinds of media (Tidal, FLAC, DSD, etc.) All

Sorry did not work, I use LAN connection not usb




On the DEQX HDP 5 Front Panel LCD screen, go to Settings, look for the Version number.
If it is NOT 0.25.03, then I suggest you contact Support at DEQX. They will send you a new version file which should solve the problem.

Let us know how you get on.

All the best.


Thanks Steven. It is 0.25.10

Is that a later version? Should it not work?


Please can you tell me if version 0.25.10 of the DEQX software has been certified by Roon.


Hey @Henry_Mancini – it looks like this device may have some pre-release RAAT software in place, so I’m not surprised that you’re having some issues here.

I’m sure everything will work once the certification process is complete, but for now we’re checking with DEQX to find out what’s going on. We’ll post some updates once we have more information.

Sorry for the trouble here!


It would be best if you contact DEQX directly. They will tell you what is the best firmware to use.

I can tell you that 0.25.03 in my HDP 5 works very well.

I use LAN input [RAAT on the DEQX - not yet officially certified], music files on a Synology NAS and Roon Server on a SnakeOil distro of Linux. It all works perfectly.

You will find DEQX to be very good with support…

Let us know how you get on.



I contacted them over a week ago before contacting Roon. No response so far. I guess they are on holiday.

Yes, they probably are…

However I suggest you contact them again and reference this thread.

All the best.


Hi Henry,

I, just last week, had Roon enabled on my HDP-5. I am having the very same problem you first brought to light (TRANSPORT FAILED TO OPEN THE AUDIO DEVICE). And, yes, the track’s metadata is dsiplayed on the HDP-5’s display.

I have been through all the posts related to this topic.

May I ask: did you find a solution to the problem?

No, I never heard back from Roon or DEQX.

If you manage to find out anything, please let me know. I hope you have more luck!

Hey guys,

This is a continuation of a thread that’s about 8 months old – let’s flag @support to see if there’s any news on this.

All ----- Just to offer an update here. The DEQX HDP5 has been tested and is certified as Roon Ready :sunglasses: :microscope:

Happy listening!

Thanks for flagging us down @RBM

Thanks Eric
Unfortunately I still see the same error message. Please can you tell me which
version of the DEQX software you are running. I am running version 0.25.10

1 Like