Devialet Expert Pro 440 has serious Roon Ready issues until cable swap

Core Machine (Operating system/System info/Roon build number)

Dell i7 desktop running latest Win 10
Roon Version 1.7 (build 511 table (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Structured Cat 6 ethernet wiring throughout house using a Arris BGW210-700 router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet Expert Pro 440 CI fed via Cat 6 ethernet

Description Of Issue

Puzzling situation…

I dismantled my audio rig to clean cable terminations and rearrange a few things. When I put it back together, Roon to Devialet via Roon AIR worked fine but Roon RAAT did not. In fact, when first tried, it made a very loud and garbled sound through the right channel which I immediately turned off. On further investigation I found…

– Roon still recognized the Devialet as Roon Ready but would not allow any adjustment of volume control from the Roon app.
– I then noticed that the Roon Device Setup for the Devialet Roon Ready audio endpoint set all the Volume Limits to 0 including the Device Limits and would not allow any adjustments (this probably accounts for the loud noise and why I could no longer adjust volume through the app).

Something was clearly wrong. Since Devialet AIR worked, I assumed that the ethernet connection was working fine.

I went down the path of reloading the latest Devialet DOS and firmware and config files. Same problem. I tried swapping my Master/Slave Dev 220s (which form my 440). Same problem. I was about to post a Devialet support ticket and post a note here to @support when, on a whim, I tried swapping the ethernet cable to the Devialet.

That fixed it! All was well again. I did put the “bad” cable back and sure enough, the problem returned. But, but, but… that “bad” cable had been working fine before I started cleaning up AND worked fine afterward for Devialet AIR. In fact, it still works fine between laptop and router. So how can an ethernet cable work fine for Roon AIR to the Devialet and other purposes, but not for Roon RAAT? Can a marginal ethernet cable do this? Why would Roon zero out the Volume Limits?

Anyway, I’m thankful it is all now working and quite willing to throw out my old Cat 6 cable… BUT ,… what happened? Anyone ever see this? @Support - any insight? And, should cables used for RAAT require a higher quality standard?

Strange that swapping the Ethernet cable fixed it, I’m not sure if it wasn’t just coincidence, but if putting it back the fault returns…? I’ve had the right amp make the noise you describe several times, usually after I’ve been messing around swapping config SD’s, and power-cycling (both sides) always fixes it… I put it down to the right half missing some config after the left half startup, as it seems to be the marriage that’s important. I wonder if you weren’t too quick with re-flashing and just compounded the problem?

At first I was certain I just didn’t get it reconfigured quite right, but couldn’t figure out why everything worked fined EXCEPT RAAT. Swapping the ethernet cable (twice!) could have just been a coincidence or perhaps just inadvertent nudging the SD card (since the ethernet cable is so close to it). I will certainly try it again.

But, my post here is primarily to try to understand what happened. I’ve not experienced that right channel noise before hence my concern.

Hello @mdconnelly,

While I can’t speak to why you are seeing the symptoms you are, I can say with confidence that RAAT shouldn’t be affected by the ethernet cable as long as it is within-spec.

To get a little specific, RAAT uses TCP to transfer the audio stream as well as other communications like transport controls, volume information, etc. TCP is used for nearly all things internet⁠—web browsing, Netflix, Tidal. To your network infrastructure, RAAT should look no different than the aforementioned examples.


John, thank you for the info. I for one was stumped when this occurred. So regardless of what caused it, do you have any insight on how/why Roon saw the Expert Pro as a reachable zone but had zero for all the Volume/Device limits and yet allowed me to select and play music resulting in the loud noise on the right channel? I’ve got to think it was some form of miscommunication between Roon & the Expert Pro but I’m scratching my head on how/why. Particularly since I was able to reproduce it by putting back the “bad” cable.

I will try it again when I get a chance (probably not until tomorrow). FWIW, with the replacement cable, Roon RAAT is playing perfectly.

Hello @mdconnelly,

We have seen this scenario when the Expert Pro has not been power cycled twice after a firmware update.


1 Like

Interesting! Since I did reload the OS and firmware and then a new config, that was likely the issue.

For what it’s worth, I just put the old ethernet cable back in and then powered the Devialet back up. Worked like a charm! Sorry for the misread about the ethernet cable.

No worries and thank you for the prompt support! Now if only I could get it to work with RAAT at gigabit speed (I’m using 10/100mbps now and it works like a charm). That issue, I’m afraid, remains a Devialet problem to fix but it’s been a year and I’m not holding my breath on that.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.