Devialet Phantom Dialog Optical Connection

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro x64 with latest updates.
Sony VAIO Laptop VGN-AW290 with SPDIF output via mini Toslink.
1Gbit Ethernet and Google Fiber 1Gbit symmetrical connection.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet Phantom Dialog with 2 Phantom Gold speakers via laptop mini Toslink to Dialog Toslink.

I am doing a 14 day free trial and this is a show stopper for me.

Roon does not turn off the SPDIF output after playing:

  • Enable Dialog optical input and enable automatic switching to optical.
  • Play from Roon to Dialog via SPDIF.
  • Play from anything (including Roon) to Dialog via Airplay - the Dialog automatically switches to Airplay.
  • Play from Roon to Dialog via SPDIF again. The Dialog does not switch back to optical.
  • Unplug the SPDIF connector from the computer.
  • After ~30 seconds plug SPDIF back into computer - the Dialog now switches to optical and plays from Roon.

Apparently Roon needs to turn off the SPDIF output when finished with it.


  • Is this possible using the laptop mini Toslink?
  • Is this possible using a USB to SPDIF adapter (I’m happy to purchase one).
  • Is there any other way to make this happen?
  • I see that the Devialet Expert is Roon Ready. Are you going to support the Dialog via RAAT?

Does this behavior happen with another application? Leave Roon out of it, if you play music to the SPDIF from another program, switch to Airplay, and then try playing to the SPDIF again with that other program, Does it switch back?

Hi @Joe_Erickson — Thanks for reaching out!

We looked into this and found that there appear to be other similar reports from other Devialet Phantom Dialog user’s. Some have reported that factory resetting their device has resolved the issue. You can read more about this in this thread.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.