Device discovery and playback issues after installation of new router [TP Link Archer GX90]

Roon Core Machine

HP Spectre 360

Networking Gear & Setup Details

New Archer GX90

Connected Audio Devices

Squeezebox x2, Google Home Mini x2, Sonos One - all wireless

Number of Tracks in Library

I use Tidal and have dropped my own library

Description of Issue

Literally nothing is working since I installed my new router this Sunday. Roon appears to see the Sonos and Google Home Minis, but will not see the Squeezeboxes. When I attempt to play on the devices that Roon sees, nothing happens and about 10 seconds into any track there is a “Roon Lost Control of the Audio Device” message.

Super disappointed that I haven’t heard anything from support after three whole days. I’ve attempted to uninstall and reinstall the roon software, reconnect devices, removed some of the internal firewalls on the GX90 - nothing has worked.

Any ideas would be appreciated.

Thank you!

This is still a valid question, as any album that has been added to the library, no matter the source, counts towards database use. In other words, the library database works as hard for 1000 local file tracks as it does for 1000 steaming tracks.

Perhaps it is the router or a setting on the router? Since that is what you changed. You might review the network FAQ to get clues what to check on the router.

I searched the website and I couldn’t find anything in regards to my router…only one other user reported anything with this particular router - and it was a different problem…perhaps I will message them and see what they did to even get it to that point.

@Stephen_Graham is the only other user I could find who had my same router. Did you have to do anything special to set it up? I can’t even get to where I can effectually connect to anything.

I’m gonna try and reset everything in a moment and see if that works.

It sounds like your new WiFi router is blocking some of the multicast traffic that Roon uses for device discovery. From a quick browse of the manual it would appear that there is a setting that may impact this, but it’s hard to tell how it would be configured by default.

First off, is your core machine (the HP) connected to your network via WiFi or an Ethernet cable? If it’s normally via WiFi does the behavior change when connected to the router with a cable?

As for router settings, try this:

  • Go to Advanced > Network > IPTV/VLAN and look at the Multicast section.
    • Be sure that Wireless Multicast Forwarding is enabled.
    • Be sure that IGMP Snooping and IGMP Proxy are disabled. The manual is unclear, but IGMP proxy may need to be enabled in order for Wireless Multicast Forwarding to work so you may need to try with this setting enabled or disabled.
  • There is also a setting called AP Isolation which is under Advanced > Wireless > Additional Settings, be sure that’s disabled.
  • Once the settings are saved reboot everything (router, core, and endpoints) and try again.

Sadly, some consumer network devices end up making some choices which break the industry standard networking protocols that Roon uses. Sometimes these choices can be overridden and sometimes they can’t. You may end up needing to return the TP Link device and getting something which has a more correct implementation of the protocols that are in use.

@Benjamin_Bear

Nothing I can think of. We got this router about a month or two ago. I was just looking at the settings to see if anything weird jumped out at me. We’re using the 2.5Gbps port for the network and the router is acting as the DHCP server. All pretty standard. From what I can see in our setup we’re pretty much using out-of -the-box settings.

MAN - I wish I was having the non-issue issue…is your core hardwired?

I’ve tried those settings to no avail as of yet…I am reaching out to the manufacturer of the router to see if they can help…in going through these suggestions, it would appear as though I may have somehow booted my WINK Hub off of the network…

I literally hate going through these messes every time I get a new piece of tech…it is part of the reason why my old router was older than my children.

Hopefully they can help me solve the problem…otherwise, back to Amazon she goes.

Any recommendations for a wifi6 router that might work without so much headache?

Thanks!

Oh, and there unfortunately isn’t an ethernet option on my laptop and I have no adapter to attempt.

Yes. All of our equipment is hardwired.

@AMP @Benjamin_Bear

Just an FYI. I have the same router with IGMP Snooping and IGMP Proxy both enabled and I’m not experiencing any issues.

The root issue here is that @Benjamin_Bear’s core and endpoints are all wireless. Most recent network devices implement multicast (IGMP) correctly for wired traffic, but things can fall apart quickly for wireless traffic.

Ultimately there are two issues at play here and in trying to address them the router is breaking Roon.

The first issue is one of security and that is that there’s a potential risk when some black box device (an IoT device like a thermostat or light controller) has the ability to communicate directly with a more privileged device (like a phone or a laptop). A compromised thermostat could start trying to take advantage of unpatched exploits in Windows to steal data or install malware. Not super-likely, but well within the realm of possibility.

The second issue is one of network performance. The absolute nightmare scenario for a wireless network is when one wireless device needs to have a very talkative conversation with one or more other wireless devices. Due to the way that WiFi works this can have a significant impact on network performance. This performance hit is further compounded when multicast is one of the protocols in use.

To address these issues a lot of consumer network devices simply block multicast traffic between wireless devices. In the case of Roon this will break device discovery. Some take it a step further and block all traffic between WiFi devices. In the case of this particular router it would appear that it’s blocking some of the traffic between devices which is leading to the state where two out of three endpoints are visible, but the proper connections can’t be setup to enable playback.

Unfortunately, I don’t think that this problem is solvable with this particular router. In the past I have had good luck with the Netgear Nighthawk products although I don’t have any first hand experience with their current WiFi 6 generation. The AX1800 or AX2400 both appear to be reasonable solutions. The nice thing about Netgear is that their software tends to do the right thing and their configuration options are sensible.

Finally, and this is really network-hardware-dependent, it’s worth ensuring that all devices involved are using the same WiFi frequency (2.4GHz or 5GHz). Sometimes things will all work great when everything is on one band, but fall apart when the traffic needs to travel between bands. This should be less of an issue with a modern device, but could still be problematic. I always recommend sticking to 2.4GHz for streaming applications as it should be supported by everything and is generally more forgiving in terms of range and structural interference.

2 Likes

@AMP @Benjamin_Bear
Fair enough. It sounds like a major benefit in my setup is that all the audio hardware and the core device is connected through Ethernet. Only iPads and phones running the Roon app are connecting through WiFi.

Yeah…this has quickly devolved into a hot mess…My previous router was a Netgear Nighhawk…I thought I could get something newer that would be a better option, but it is not working out right now. I think I might just have to bite it and do something else. Unfortunately hardwiring is not an option for me in this older home and with the equipment I have.

I have burned a whole day trying to get this to work!

I just boxed up the GX90 and requested an Amazon return. I am going to attempt an Asus unit next…hoping that it works - otherwise I might spring for the newer Nighthawk - though at nearly $600 - its up there!

Thank you all for your time today.

Happy listening!

If hardwiring is not an option have you considered power line ethernet? Its solved connectivity problems for me in locations with poor WiFi signal.

I tried the ASUS units recommended by wirecutter, speed was incredible but I had issues with the subnet, all devices need to be on a single subnet and the ASUS created a second one, as a result I could only ‘see’ half my devices so the ASUS went back to Amazon.

1 Like

Well - SHOOT! That might happen to me as well…this is why I don’t upgrade equipment very often!