"Device Initialization Failed' attempting to add Chord Hugo 2, Win10

Core Machine (Operating system/System info/Roon build number)
Dell XPS 13 7390, Windows 10.0.18363, Roon 1.7 Build 610 64bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
standard network equipment, no network issue

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Chord Hugo 2

Description Of Issue
I have installed the latest Cord Hugo 2 driver, downloaded again today from their site. I have confirmed in Windows Control Panel > Sound > Playback devices > Properties that the driver installed is

The Hugo 2 (connected via a USB C to UBS mini cable) is recognized by Windows, and I can play audio through it using a browser / Youtube as well as through the TIDAL standalone app (exclusive mode or not).

When I open Roon > Settings > Audio, the Hugo 2 appears in the list of options. When I click Enable, I alternately get the error message shown below ( "Device Initialization Failed’ ), or Roon crashes entirely.

I have tried reinstalling the Chord driver various time without success. I have tried different USB C cables, and also connecting a USB hub and using a known-good USB A to USB mini cable. However, given that I can play music from other apps via the current USB C cable I do not believe there is a USB problem.

This very frustrating, please advise.

Hi @Ted_Redelmeier,

Was this device working in Roon previously? If so, was there any change to your setup around the time it stopped working?

Hi there. I’m a friend helping the original poster.

The Hugo 2 has never worked on this Dell computer with Roon. As noted in the OP, the Hugo 2 does work with Windows / other applications on that computer. Also, the computer in question can be used to control other Roon endpoints on the network, etc., without issue.

Please advise - is there a log file or something we can send you?

Try making sure your Realtek drivers are the latest. Realtek drivers can be problematic.

OK. Are there instructions on how to do that?


The above is the link to Dell’s driver and download support. Double check that is the right laptop, then choose Audio in the category and download the June 2020 driver. Also, sometimes Dell has a driver manager might have already done this install, so I’d check that first.

If this is all unknown territory, call Dell support as they can help you check and get the latest version installed.

I have had similar issue using front PC desktop usb port to connect my Chord Mojo. Unfortunately that usb port was not connected properly., by moving to use port embedded in rear on motherboard, device worked well. Might be helpful for others to resolve such issue :slight_smile:

Hi @Ted_Redelmeier / @qrd_skyline,

I would also check the firewall on the DESKTOP-SOHRDL9 PC.

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

the solution to roon not playing through the hugo2 with a roon core on the local computer was solved by updating the realtek drivers.

the solution to roon not playing through the hugo2 with a remote roon core was solved by adjusting the firewall in accordance with the above suggestions.

thank you all


Hi @Ted_Redelmeier,

Happy to hear you sorted the issue out!
If you run into any other issues or questions, please just let us know!

thank you very much

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.