"Device not found" on Linux USB audio DAC (ALSA) on core machine

Roon Core Machine

Home-built Ubuntu kernel 5.4.0-131 kernel 32G RAM

Networking Gear & Setup Details

Connected Audio Devices

Signstek mini USB DAC.

Number of Tracks in Library

A few thousand

Description of Issue

See subject. This used to work. After the last upgrade it stopped working. If I unplug the DAC then it disappears as a choice and if I plug it back in Roon says “device not found”. Linux is perfectly able to play music to it, just ROON can’t.

The last upgrade was pretty troublesome too. After the upgrade to stop working then I kind of had to uninstall everything and reinstall it. So who knows. Maybe something went wrong then.

It’s been nearly two weeks since I reported this. No one has a suggestion on how to proceed on this?

Hi @Alan_Robertson1 ,

Apologies for the slow response here.

Can you please reproduce this behavior and let us know the exact local time + date when you next see this behavior? We can enable diagnostics and see if there are any specific errors being shown. Also, do you have any Mac or Windows PCs you can run Roon on to check if the behavior also occurs there?

27 January at 0630 (approximately). I tried disabling then enabling. No change. I then unplugged it and plugged it back in. It appeared to be enabled, and I heard a click, but when I tried to play,bit said device not found again.

At about 0649 I connected this DAC to my Mac. It worked fine. Apparently, something needed upgrading, because it kept reconnecting to my core rapidly. Upgrading fixed that.

At about 0654, I plugged it back into my core, and the previous behavior repeated itself. My Linux box states that it runs out of support fairly soon. I might as well do the upgrade. Maybe it will help?

As a reminder: this DAC works fine with other audio apps, like YouTube videos, etc. Just not with Roon.

I updated some packages and rebooted as part of the upgrade process. This seems to have fixed it (??!!).


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.