Device not showing after new laptop w/Win 11

Roon Core Machine -

1 TB Roon Nucleus

Networking Gear & Setup Details

FIOS Routher wired to Ethernet. Same ethernet that Nucleus is wired into.

Connected Audio Devices

Lenovo Yoga 9i - i7, 16G ram Win11. Replaced 5-year old Yoga 7i, 8G ram Win10
Laptop is connected to a Plugable docking station which is connected to a Mac Time Capsule which is connected to Ethernet outlet on wall. Setup worked with the prior Yoga w/Win10.
Roon endpoint is a Bel Canto DAC hooked up to the Yoga laptop with a USB 2 b cable (same cable that was hooked up to the Yoga 7i).

Number of Tracks in Library

3000 tracks maybe 1TB nucleuse

Description of Issue

I replaced my laptop, which has a bel canto DAC hooked up to the laptop with a USB cable.
The Roon app works and the Settings-Audio shows my DAC+ that is hooked up to the Nucleus enabled and shows a networked Homepod also enabled, but does not show the Bel Canto at all. The laptop is hooked up indirectly to the network by Ethernet (through a docking station hooked up to a time capsule).
So I don’t know if the problem is the laptop, Win11, the latest Roon update or what???

Try turning the firewall off temporarily as a test. If it shows up try allowing a cess to roon and raat processes

Under Settings, More Devices, it shows under Audio my Bel Canto 2496 USB with a little green dot. Also, Windows System > Sound > Properties successfully plays test sounds and volume works.

Under Windows Security Firewall & network protection, all the activities are grayed out, including “Allow an app through firewall”
Also, on McAfee Livesafe that came with computer - I turned off Firewall and tried Roon again but still no luck.

Still sounds like a Firewall issue to me. Are you sure that in turning off McAfee (temporarily) that the default Windows Firewall didn’t kick in?

1 Like

The McAfee firewall has something to do with it. When I turn it off, the Windows Defender firewall is also off. McAfee has a bunch or setting to control apps in general and individually. Fiddling with that didn’t do anything. Meanwhile, here’s the latest…
If I go to Windows System > Settings > Pair a new input device > Add Device AND turn off the firewall, a whole new section “Audio” “This PC” appears and shows 4 devices: System Output, Bel Canto, Plugable Audio (my docking station) and Realtek(R) Audio. So it is working at this point. None of the devices show up in the Add Device list, the devices suddenly appear in Roon. Closing the Add a device window doesn’t shut down the Roon access, but shutting down the Firewall does. Both the Firewall has to be off and the Add a device window have to be open to get the Bel Canto to show up and work. Don’t understand the Add a Device connection. And need to figure out which of the McAfee firewall settings needs to be tweaked. There’s a bunch of ports not turned on; I tried fiddling with those but nothing happens. Any new guesses? Will Roon tech weigh in on this or do I need to contact them separately somehow? Thanks Geoff.

Make sure the raatserver.exe process is being allowed through all the firewalls.

Personally, I dumped McAfee aeons ago - Lenovo are apparently still delivering oodles of bloatware with their PCs it would seem.

Microsoft’s Windows Security (antivirus, browser, firewall and network protection) is perfectly adequate for me.

Hey @Paul_MaybeAudiophile,

Great troubleshooting you’ve done so far!

Please follow the steps in Adding Application Exception to McAfee Firewall to add Roon as an exception to the firewall.

Additionally, you can try changing the router’s listing to a Home network in McAfee: Mcafee Firewall settings for Roon 1.7 - #7 by Anthony_Lombardo

A third solution is to change the security level of Roon and RAATServer: SB3 won't connect to Roon Sever with McAFee turned on - #9 by Jeff_Barham

Let me know if any of the above work for you. :+1:

I remember seeing something about the Raatserver but couldn’t find it. Ultimately, I removed McAfee and loaded Norton which I had on my other computer. Seems like the problem is now solved. Thanks for your help.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.