Device Volume Issue

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Hello, @support. I have set up a microrendu as a Roon endpoint in my living room. I have it set for Device Volume but when playing any track, it shows and acts as Fixed Volume. I have disabled and reenabled the microrendu. I’ve rebooted it and the DAC. I’ve changed from Device to Fixed Volume and back. None of these solves the issue. I don’t know how to fix this.

Screenshots attached. Running Roon core on WS2019. DAC is PreBox S2 Digital.

Thanks for the help. JCR

Hey @Jeffrey_Robbins,

Thanks for taking the time to write in! Before digging into your issue further, please edit your original post to include more details with your setup. Please be as specific as possible with this information as it is immensely helpful for the support team.

We’ll be monitoring this thread for your reply :+1:

I am not a MicroRendu user… but don’t you have to set volume control within the settings for the MicroRendu itself? So not just within Roon, but also on the Rendu’s settings page? This can be accessed while going to this website:

Thanks, I tried the max volume button in the microrendu DAC Diagnostics app, but that did not solve my issue.

Ok, back to setup for Roon @support. WS2019 core with Audiophile Optimizer running; i9-10100K processor; hard wired to network; as noted, microrendu to PreBox S2 Digital DAC. Audiolense convolution filters engaged.

Device volume works if mr is set as NAA and I play HQP out through Roon. Device volume also works if I use a rpi3B as NAA and play HQP out through Roon. But not with the mr set for Roon app. Roon core is v.1.8 (988 build, but core just updated to 996 and still the same — stuck on fixed volume). JCR

Hey @Jeffrey_Robbins,

Thank you for the information. What version of Sonicorbitor are you currently on? In the past, we’ve seen users run into issues when on version 2.3, but were able to fix the issue by upgrading to 2.5. I am wondering if this might be a similar situation after you mentioned device volume working in other scenarios.

Another potential workaround here would be to set for Device Volume and use DSP volume to attenuate the volume. That said, this can beef up your CPU usage.


I’m on v2.8, which is the latest available for microRendu. I’m not following your other suggestion. My choices are Device Volume and Fixed Volume.

My second microRendu, in my main system, runs HQP NAA through Roon. It is also set for Device Volume. If no track is playing, and I pull volume up in Roon, Roon says volume is fixed. But then, as soon as a track starts to play, Roon allows me to control the volume.

For the microRendu in question, in my living room system and set for Roon and not NAA, there is no shift of volume control from fixed to usable in Roon when a track starts to play. Rather, it blasts full 100% volume, nearly frying my speakers and ears.

And I should mention that if I use the app switcher in the microRendu and set the living room device to NAA, it functions just as the microRendu in my main system — fixed volume until selecting to play a track, and then volume-controllable through Roon. So, this must be a Roon issue? JCR

Hey @Jeffrey_Robbins,

To confirm, have you enabled device volume from the settings in sonic orbitor? You’ll need to have this enabled in order for the micoRendue.

Also, when did you first run into this issue?

Thanks, Jeffrey

Hello, @benjamin. There is no setting to “enable” device volume within the rendu, that I can see. Under DAC Diagnostics, I can set the DAC to maximum volume, but I already had done that. If there is something different I need to do, I’d appreciate knowing where.

This started only when I decided to use the rendu as a Roon endpoint. Previously, it was set as NAA and device volume control worked fine (that is, in Roon, the volume going out to HQP was controllable and not fixed). JCR

Odd that this interface does not appear on my rendu — that is, using my iPhone to go to that screen. I just tried using a PC to access the rendu and, lo and behold, there was the same page you are showing. Of course, setting the rendu to software for volume instantly resolved the issue at hand. Thanks much for the assistance. JCR

1 Like

Happy to hear that! Mobile interfaces often are missing essential features. Happy listening!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.