Devices disappearing from Roon

Core Machine (Operating system/System info/Roon build number)

Roon Rock Core 1.8 build 756.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Imac over ethernet

Description Of Issue

This may be two problems instead of one…not sure.

This morning while sitting at my Imac with Roon open, my Imac did not show on the audio zones. If Id go to setup/audio it is there and enabled but it does not show as an option when selecting where to play music on the main screen. I tried disabling and re-enabling the imac in settings but that did not help. I tried rebooting the roon client on the imac but nothing. I fixed it by rebooting the roon rock itself.

Yesterday the roon rock shopped showing in my network options. I was still connected to it and playing music but it did not show a sharge for me to copy music into. Rebotted both Imac and Roon rock and that fixed it.

I had a similar issue this afternoon. I was not able to choose any audio zones except Sonos speakers and notebook speaker. All of the others have been disappeared.
I just installed the newly arrived Remote Android version (748) now I’m able to choose the mobile phone (Samsung S10e on One UI 3.0) as an endpoint. I just updated Ropieee on my RPI4 to solve this issue, but it was not helpful.
The solution I found finally, I had to reinstall the Core on my Asustor NAS (old version was 756, the new version is 756 too), and now all audio zones are visible and I can play the music.

Update: my phone is gone again

I am having the same issue too - would like a serious update that will mean I don’t have to reinstall Roon ROCK every afternoon.

I’m having the same problem. Having to restart RoonServer on my Linux box every day right now because outputs keep disappearing.

Same issue here. Rebooted router and modem and Roon then showed the streamer as a device. Closed things down and tried again about an hour later and lost the connection to the streaming device - again. The streamer is a Roon supported device and I had no problems until the update to 1.8.

There is a ticket open for this issue… @moderators please add this to the thread

I’m having the same problem. I having to restart my Nucleus every day because outputs keep disappearing.

There is a ticket in for this… @moderators can we get sticky on this issues please…this is like the 5th post I’ve flagged in the last hour or 2 @support

Apologies for the trouble! We’re working on a solution to this and will keep everyone updated here:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.