Different device showing at Rock IP adress

HI Roon team, I hope you can help me with this one.
I moved into a new apartment where I installed a new network, with a new modem and router.
After setting up my system, Rock worked for a few seconds and then I lost connection.
When I open the IP address for ROCK, I find another player on my network (a BlueSound).

Maybe the problem is that I had ROCK configured with static IP… not sure.

My actual set up is :slight_smile:
Fiber Modem Router > Gigabit switch > Rock
All my other devices works fine.

Is there a way I can change Rock IP address?

I’m not sure either. :wink:

If a (maybe) dynamically configured BlueSound has got the same address as your (probably) statically configured Core, then disconnecting / powering down the BlueSound should make the Core accessible again so you can change the settings there.

You should also check the DHCP settings of your router. If your router has the address of e.g. and the DHCP address range is set to 2 - 254, then you should reduce the range to e.g. 2-100 and use addresses from 101 upwards for devices you wish to configure with static addresses. This should prevent such address conflicts in the future.

1 Like

Hi @alessandro_niola,

Are you able to access the Nucleus Web Administration Interface?

Hi Dylan,
no, it gets stuck on looking for devices on my network

Also, here is a summary of my network :slight_smile:

Hi @alessandro_niola,

Have you used an app like Fing to scan the network and see IP addresses of the devices located on your network? It would be good to confirm that ROCK can be seen on the network and whether or not another device is using the same IP address.

Can you confirm the models of the switches on your network here? Are they managed switches? Did they exist in your previous setup?

Not a good practice to set a static IP, because of what you are experiencing. A lease has expired on another of your devices and DHCP, because it doesn’t know about the static IP assigned with ROCK, has assigned the same IP that ROCK is currently using.

Go back into ROCK and set it to use DHCP. Go into your router software and reserve an IP address for the ROCK device. This is the only safe way to permanently assign an IP to a device, which is what I assume you’re trying to do.

You’ll probably have to take the conflicting device offline so that you can get into ROCK.

Really don’t understand why ROCK was designed to even give an option to assign a static IP.

Thanks everyone, I was able to fix it.
I disconnected the NUC from my network and re-connected it. For a moment I could see it at its original IP address and I took that chance to change IP settings from static to dhcp
All sorted, working like a charm now!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.