Difficulty with Airplay connectivity on two Denon receivers after switching ISP (ref#3DDTJ9)

What best describes your playback issue?

· Other

Is there a specific error message you see? If so, please select from the following options:

· Other

Please try to reboot your Roon Server and check to see if this helps.

· Rebooting my Server had no effect, the issue remains

Please try to reboot and unplug/replug in your affected audio device and check to see if this helps.

· Rebooting and unplugging/replugging my audio device, the issue remains

Please open your Roon Remote and select the "System Output" Zone and try to play to it. Do you encounter any playback errors with this Zone?

· I can play back music *without issue to System Output*, it is only the *other zone that has issues*

What method is the audio device connected with to the server (Roon Ready, HDMI, USB, AirPlay, Chromecast, etc.)?

· Airplay

Is the audio device on the latest firmware version, as per the manufacturer's app?

· Yes

Is there any change in behavior when using a different cable for the connection for the audio device?

· No, using a different cable didn't change anything

Have you reached out to the manufacturer of the audio device regarding this issue yet?

· No, I have not reached out

Does the issue happen with local library music, streaming service music, or both?

· Only local content while streaming works fine

Where is your local content stored?

· On the same machine where RoonServer is running, internal drive

Please try playing content of a lower sample rate (44.1kHz or 48kHz), does this work as expected?

· No, lower sample rates are still affected

What is the model/manufacturer of the affected audio device(s) and the connection type?

· Denon AVR-X4500H & DRA-800H (Ethernet both)

Describe the issue

This helps our team gather all the necessary information to solve your issue as quickly as possible. Thank you!

Hello, I recently switched ISP and that is when everything went to crap. I have slowly worked through many issues (ARC, wireless speakers, general setup). Just about everything is working. I just tried my receivers - which I assumed b/c they are plugged in with ethernet there will be no problem. I have three receivers, one worked fine first try, two others are not playing. I hit play button - it waits around 3 seconds and then the play button comes back (as if it is trying and getting no response). Now, I am likely not the savviest of users on here, but I did try several troubleshooting items to get as far as I can:

I reset, and power cycled the Denon receiver
I tried an alternate music source (Apple Music) which recognized the receivers and played just fine!
I tried other ethernet connected endpoints (two oppo blu-ray players) those played just fine.
I then disabled and reenabled the two receivers, then entered the airplay code.
I used the HEOS app to ensure that they were discovered there (they were)
I tried to “flush” them out of the Roon system, by unplugging them and power cycling my modem, thinking since I switched ISP perhaps there is something old there from previous modem preventing connection - that worked, in the sense that it then did NOT show up in Roon, and when I plugged it back in and hit refresh it then found it again, and I reentered airplay code. STILL nothing worked.
so that is why I am now coming to the community. I am out of ideas. these were all working prior to switching ISP and it is frustrating because it is so random. why do they play and discovered on Apple Music? why does one of my three receivers work fine and the other two do not?

Please let me know if you have any other hints or suggestions to try and I will try them. One of the receivers I can honestly live without working because I have both the Roon core and the oppo plugged into it (so two other options, both of highest quality audio) but the one in my garage Airplay is the only source so I need it to work as it did before switch (TMI? - lol).

thanks to you all in advance!

Describe your network setup

ORBI, Verizon wireless home internet, AVR-X4500H and DRA-800H (AVR-X8500HA works fine under same circumstances)

Hello @Karl_Mayhew ,

Thanks for reaching out. Can you please try to toggle Device Setup → Airplay compatibility mode for the problematic zones and let us know if this helps with the issue?

Hello! It did not help. The only change I noted was with that mode off, the play button came back after like 6-8 seconds and with compatibility mode switched on, the pause button stayed on indefinitely (but play never did start)

Hi @Karl_Mayhew,
If you try to manually click somewhere in the seek bar when in this state, does playback temporarily work?

Assuming you are referring to snip below, then no. there is no change by clicking or sliding during playback attempt.

Another item I discovered in troubleshooting:

If I am in Roon attempting to play - then I go into HEOS app - it shows whatever I was trying to play as current song. If I then hit play inside HEOS app, it will turn on the receiver (whereas attempting the same inside Roon will NOT trigger a power on of receiver). In each case end result is it will not play, but it goes a step further from HEOS app. Lastly, I noticed that the receiver display shows Tune-in, not HEOS or anything else sent from Roon. not sure that helps, but want to keep trying and keep this chat active until resolved:

Only Roon Ready zones can be woken by Roon. Since the HEOS is using AirPlay Roon will not be able to wake it.

I will continue to investigate the AirPlay connectivity issue.

strange, this has 100% of the time worked for past several years. I have never had to manually turn things on and change inputs. in fact, my AVR-X8500HA (the only one of three working for some reason) wakes it every time. so that is news to me based on past experience/expectations.

Other users have experienced success after adding AirPlay devices to their Apple Home App before trying to connect. Can you try that?

Hi @Karl_Mayhew,
We’ve figured out that the Denons are telling Roon that they need some kind of authentication to play. We’ve enabled an option on your account that may help with this. In order to finish the activation we need you to restart your server twice.

Hi Daniel, my receivers are all already connected to Apple Home Kit. Let me know if I need to remove it and reinstall it.

Hi Daniel, I power-cycled my NUC twice and then tried again. there is not any changes I could see. In case whatever change you made takes a while to download or work or whatever, I will try again later this weekend. I have meant to call denon in case they are either aware of something already or just have basic resetting suggestions, but their hours are kind of limited and they are on east coast, so I need to call them before like 3 PM and I just haven’t had time. thanks for all the attempts you have made so far.

I realize this may be totally irrelevant but are you able to connect to airplay with the Heos app and your receiver?

In the advanced settings for the device there’s the ability to use an airplay password.

I don’t use airplay (other than trying to avoid conflict with RHEOS) but maybe this could help:

Hi Peter! Thanks for the thought, but yes, each time it asks for the password I apply it. Also, I can trigger the Denon to turn on and play music via HEOS app as well as Apple Music