DigiOne on RPi: Can't be Found By Roon

Ugh! Starting to think I have an odd looking paperweight…

I have a raspberryPi 3+ with a DigiOne board installed.
The boot image is DietPi with Allo GUI. It has been updated to the latest build v6.22.3.
The DigiOne sound card has been selected.
It has an IP address and can initiate the GUI via its IP through the web browser. I can also ssh into it using the IP address
Roon Bridge is installed and active. The device is connected to the network via ethernet and to my DAC via S/PDIF.

Despite all of this it doesn’t appear in Roon and I get no indication of any digital data passing through to my DAC. I’ve included the results of the “aplay — list devices” command which appears to show the DigiOne sound card enabled:


At this point I’m completely stumped and wondering if there’s something obvious that I’m missing. Perhaps there’s a hardware issue involved?

Any thoughts are appreciated.

I would suggest using Ropieee.

Have you enabled in Roon?

Hello @Michael_Guerra,

Can you please post a screenshot of your Roon Settings -> Audio Tab? You can use these instructions to upload screenshots to community and this tab should look something like this:

After posting that screenshot I would also confirm that both Roon and RAAT have been added to your OSX firewall by using these instructions and if you have any additional antivirus or firewall blocking applications (such as Bullguard, Little Snitch, McAfee, ect.) I would see if there is any change in behavior after temporarily disabling this.



Thanks for the quick response. Let me tell you where I am so far:

I took @Progisus suggestion and tried the Ropieee image. With Ropieee, I was able to find and enable the Device and the DAC… unfortunately only when it’s set up and connected as a USB Device. In other words the s/pdif connection doesn’t seem to be transmitting data at all.
I’m beginning to suspect a hardware issue, unless there’s something somewhere that needs to be turned on.
The DigiOne card shows a steady green led so it’s receiving power.
The s/pdif cable is good as far as I know, and unless something has changed very recently the DAC s/pdif connection is fully functioning.
Troubleshooting further I’ve tried testing the DigiOne with my primary DAC( Mytek Brooklyn) and it shows “no lock” via s/pdif with that DAC too.

The first screen shot below is with the USB box checked in Ropieee. In the zone “Tubular” you can see that the DigiOne and Grant Fidelity DAC are visible in the audio settings. For some reason the DAC appears twice.
In this case there’s sound via the DACs USB input. This seems to defeat the purpose of the DigiOne, since I’m assuming that in this configuration, it’s not isolating the power from the PI. Is it even using the DigiOne sound card at this point?

The next screen shot is with the USB setting turned off:
In this case, the DAC disappears from the audio settings list and there is no sound at all.

I don’t know if any of this info will help. Thanks in advance for any further suggestions!

Hello @Michael_Guerra,

I’m starting to suspect that this could be a hardware issue as well. I’d like to see if diagnostics might help out here, can I please ask you to do the following?

  • Rename the Tubular zones to something that will allow us to differentiate them there, something like Tubular USB1/Tubular USB2/Tubular SPDIF

  • Try to start playback on the SPFIF zone

  • Note the exact local time in your country (e.g. 2:54PM on April 1st) of when the playback attempt happened and let me know


Hi @ Noris-
Played Tubular S/PDIF at 5:52 on April 1. It worked!!!
Not sure what was going on but I think it may be solved.

Thank You!!!

Hi @Michael_Guerra,

Thanks for letting me know that the SPDIF output is now working. It may have been due to having the same name for all of the zones, either way glad that it sorted itself out.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.