Disabled explicit badge, yet still shows occasionally

Even though I have disabled the explicit badge in settings, it still pops up on some releases. Ex below.

Anything I can do about this?

Hello @RBO,

Sorry about the trouble and thanks for letting us know.

When you see the badge appear, if you go to Settings, is the toggle still off for explicit badges?

Hi @beka

Yup, disabled and it still appears. Looks like a bug :slight_smile:

Appreciate the quick update, @RBO.

I’ve taken this to our team for investigation. Thanks for bringing it up.

We’ll follow up with questions and/or next steps :nerd_face:

Hi Rebeka.

Any chance the team managed to find what is causing this?

Hello @RBO,

Thanks for following up on this. Please, allow me to check. I’ll follow up early next week (as you probably already know, support is closed over the weekend)

1 Like

Thanks and enjoy the weekend.

I believe that the setting only turns the E off in the album library view, but not on the cover of the individual album. It is easy to check, simply edit any album by ticking the “explicit = yes” box, and there is the E on the album cover.

IIRC this changed in 1.8. I thought it was intended but never liked it as it makes no sense, but with the many changes and issues in 1.8 .it was sometimes difficult to be sure


That worked. Cheers :slight_smile: But I’d rather not have to do this for every single album which needs it done.

1 Like

Indeed. It was just meant to demonstrate that the issue seems to be that turning off the E badge in the setting does not affect the badge in the individual album view. Even with the badge disabled in the settings, you can make any album show the E by ticking the box in the edits. I agree that this seems like a bug, why would I want to see the E on the album cover if I turned off the E badge :slight_smile:

1 Like

Thanks for pointing this out. I searched the forum here and could not find a solution. You’re the first one to explain this to me :slight_smile:

1 Like

Thanks @Suedkiez for taking the time to share this. As promised to @RBO, checking with the team to confirm :nerd_face:

1 Like

Hello everyone :wave:,

I wanted to follow up to let you know that I’ve taken this thread to our QA and technical teams. They are aware of this behavior and looking into it.

We’ll share updates on this thread as soon as we have them :nerd_face: