Display problems - Mac

I’m having some display issues. I’ll try my best to describe them well.

I’m running Roon - both the core and control - on a headless Mac Mini (High Sierra), using screen sharing from a 2012 MacBook Pro (Mojave). When I would screen share all was fine - the Mac Mini screen would open on the 1280x800 display of the MacBook, and fill the screen nicely and resolution was good (i.e. text was a big enough size). Then last night I used Apple TV Airplay to show what was playing on Roon on the TV. When I go back out of using the Apple TV things got all out of whack. The screen resolution was too high so that all the text is too small, and I’ve tried every adjustment I can think of to try and get things back to the way they were, but with no luck.

As an alternative I tried running the Roon control from the MacBook, but I get an error message saying that the screen resolution is too small. I can enter full screen mode, then hit the green button to get out of full screen. All is fine then with one exception: the Roon app still uses the entire visible screen, which is OK except that the dock covers up part of the “what’s playing” info on Roon. I can change the size of the Roon window side to side, but not vertically. I know I can have the dock automatically hide and show, but that’s not my preference.

Any thoughts/suggestions?

Which device did you ‘cast’ to Apple TV via Airplay? The MacBook Pro, or the Mac Mini?

The Mac Mini

I have essentially the same setup as you. A Mac Mini as my core and a Macbook Pro (and iPad) as Roon Control.

I use my Mac Mini Headless, but also connect it to my AV Amp and onto my TV via HDMI (For listening to Multi-Channel audio and watching video).

I use Remote Desktop on the Macbook Pro.

Now… what I reckon may have happened when you used Airplay was the resolution of the Mac Mini was changed to match your TV, i.e… 1080P (1920x1080). You say the writing is now smaller via remote desktop?

To get it back to a more viewable size on the Macbook Pro, you need to go into “System Preferences - Displays” on the Mac Mini. Choose “Scaled” and something like “1280x720”. This is quite a low resolution, and will look good on Remote Desktop on your Macbook.

The reason the Mac Mini did not change it back, after Airplay was used, is because it doesn’t have a display connected, so didn’t think it needed to. If you have a display connected and resolution set to “Default for Display” the mac mini will reset according to what the display demands.

If you really want to do Airplay from the Mac-Mini, then I think if you select “Scaled” rather than “Default For Display” in “System Preferences - Displays”, hopefully, the Mac Mini will keep the lower resolution that is good for viewing on your Macbook Pro. (However it may not look as good when sent via Airplay to the Apple TV) ( I don’t know this for sure because I’ve never used Airplay as I don’t have an Apple TV)

Now… If you have the option of using Airplay from your Macbook Pro instead… I would suggest that since you are using the Mini headless, you should use Roon Server on the Mini, not full-blown Roon.

You should use full Roon on your Macbook Pro, but use it in “Roon Remote” mode and have it connected to your “Core” - the Mac Mini.

You said you did this and you got an error message saying that the screen resolution is too small? That is strange… My Macbook Pro screen resolution is also 1280x800 and I get no such message. Hmm…

When you go full-screen mode, unfortunately… you are right… the dock covers the playback bar. I haven’t found a way round this, but I use the dock in Auto-Hide mode and always have, so it’s not an issue for me.

Sorry if some of my latter suggestions don’t work for your use case, I’m trying to visualise how you’re using your different components.

Hope some of this helps. :slight_smile:

Yes Thanks, Dan, a lot of that helps. I really ought to be controlling Roon from the MacBook, rather than screen sharing the Mac mini - like you have yours set up. You mention that you use the MacBook in Roon Remote mode - is there something special I need to do to accomplish this, i.e. some setting that says “This MacBook is only for Control”? I have the Roon app on my MacBook using the Ayre DAC (Zone) that’s connected to my Mac Mini and am getting a Lossless signal path. Is there something else I ought to do as well?

No, in terms of control, on the MacBook Pro, you’re doing the right thing.

You use the full Roon software, but when you first fire it up, it asks you if you want to connect to an existing core, which you must have done because you’re controlling the core which resides on your Mac Mini. So… all good there. You did say the ‘core’ was on your Mac Mini right? Am I getting this right?

Regarding your core… You can use “RoonServer” rather than full-blown “Roon”.

RoonServer is a more trimmed-down core that doesn’t have a User Interface, ie. no graphical capability. You can only control it via Roon Control, either externally to the Mac Mini, as you do, from your Macbook Pro. (or IOS device or Android device), or, if you want, you can load up a version of full-fat Roon along side it on the Mac Mini if you want to do some control on the Mac Mini.

The reason I advise using RoonServer is because there’s less processor overhead on the core machine which… some say… makes for better sound quality if your DAC is connected via USB. I don’t know the Ayre DAC… is it connected by USB?

Hello @Michael_Turner,

I just wanted to check in here with you and see how you were doing with switching the Macbook to Roon Remote more and if were still experiencing issues with the screen resolution. Can you please let me know if you require further assistance on this topic, or is everything working as expected?


Thanks for checking in, Noris. It was very easy and everything is working great. It was mildly disconcerting that there is no way to know that Roon Server is actually “on” (other than music plays). Of course Activity Monitor shows a couple Roon processes, but all in all things seem to be working just fine. I haven’t actually deleted the old complete Roon application yet, it’s just turned off. I guess at this point I probably can just go ahead and move it to the trash, yes?



You should see the Roon icon in the menu bar when RoonServer is running. You can also quit RoonServer from there if you need to.

See below…

Hi @Michael_Turner,

Glad to hear that you’re up and running! Yes, the Roon Server would appear in the top bar as @Dan_Brown showed in his screenshot and you can access the menu options to exit RoonServer by clicking the icon.

As for the previous Roon App you have installed, you can still leave the Roon App installed and use it alongside with your RoonServer. In this case though, you would want to select the RoonServer as the Core and not choose “Use this PC as the Core” when the Roon App starts up.

By having both, you can use the full Roon app as just the “Control” aspect of RoonServer while keeping everything else constant and it useful when you want to change tracks or make some slight config changes directly from the machine that hosts the Core. If you do not wish to take advantage of the Control aspect, then you can go ahead and uninstall the Roon “All-in-One” but do be careful not to accidentally remove your working RoonServer.

I would also highly suggest keeping regular Roon Backups of your Database just as a precautionary measure in case something ever goes wrong or you simply wish to transfer your database to another Core in the future. Hope this helps!


:+1: Thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.