Distortion of hi-rez audio files

Core Machine (Operating system/System info/Roon build number)
Mac desktop.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Hardwired Thunderbolt.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
HDMI --> Oppo 105 preamp/DAC/disc player.

Description Of Issue
I began my trial period with Roon a couple of days ago.

Roon easily recognizes, imports and processes the files in my primary library folder, most of which are ripped from CDs into AIFF. It all looks and, more importantly, sounds good.

The problem arises with the couple of hi-rez downloads I’ve attempted to play through Roon. The first, a 24/96 file in 5.1, tested just fine through another music player (Vox) before I loaded it in the folder for Roon’s attention.

Through Roon, however, the sound is full of clicks and pops that rise and fall roughly with the dynamics of the music. Thinking these distortions resulted from adjustments to surround settings I had just performed in the Roon menu, I downloaded a second hi-rez file, this in stereo DSD64, and loaded it in the folder for Roon. The same phenomena occur as with the 24/96 file, while elsewhere the CD quality files remain unaffected.

I hope I’ve been plain enough describing what is going on so that one of you smarter-than-I guys can help me figure it out.

Hello @Michael_Harrison,

Try disabling the “Exclusive Mode” option in the “Device Setup” screen for the Oppo 105 HDMI zone.

If this resolves your issue, the issue most likely is a result of a compatibility issue with the Mac and Oppo during high resolution playback.

Are you using “Exclusive Mode” in the Vox music player? As far as I am aware, Vox requires a premium subscription to use “Exclusive Mode”.

If you are not using this feature in Vox, disabling “Exclusive Mode” in Roon will be equivalent to the normal Vox music player audio playback.


You are kind for giving me a possible solution. I’ll give it a try and get back to you. M

The audio distortion remains with or without Exclusive Mode enabled. Good idea though. I’ve deleted and reloaded in Roon the two hi-rez files I’m using as test cases. Still no go. Vox shows and sounds like its playing full resolution, clear multichannel with the one file, and I have no subscription with them. I agree that it must be a compatibility issue.

Hi @Michael_Harrison,

Can I please request that you upload a screenshot of your Signal Path when these tracks are playing? Signal path looks like this for reference:

I installed Roon on a late 2012 Mac desktop version 10.15.3 running Catalina, converting the thunderbolt output to HDMI input for an Oppo BD105, a multichannel universal disc player and preamp. The files of my music library are predominantly AIFF ripped from cds and stored on an external hard drive. It should be an easy setup, and initially it was. Roon’s presentation, functionality and sound are exceptional.

Then I began experimenting with higher resolution downloads and multichannel playback and experienced audio distortions, mainly of persistent popping and crackling sounds. This happens with no other audio source or playback process between the Mac and Oppo. Only with Roon. As I’ve tried various solutions in the Roon and Oppo settings, the problem has gotten nothing but worse, beginning to effect the cd quality stereo files which initially were fine. I now suspect the audio midi settings in the Mac but don’t know.

I’m attaching an image of the Roon window signal path.

Hi @Michael_Harrison,

If you connect your Oppo via USB, do you experience any of the distortions on the higher-resolution content? Or does this behavior only occur when using the Thunderbolt -> HDMI connection?

Have you tried a few different media tracks and the behavior is the same on all of them? If you have a limited library of multichannel tracks, you can download a few more samples from the 2L Test Bench.

I appreciate your help in trying to resolve my audio problems with Roon. But I give. Until I’m better Roon equiped–and I may be soon–I think the program is not for me this go round. Thanks for the try out period, your support and what seems to be a great customer base of interesting people.

1 Like

Hi @Michael_Harrison,

I appreciate your feedback here! I will go ahead and close this thread for now, and I have also followed up via private message.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.