Does Rock override NUC Bios Fan settings?

Core Machine (Operating system/System info/Roon build number)

NUC8i5BEH / latest Bios Version 0081 with Roon Optimized Core Kit also latest version

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

1GB Ethernet wired LAN

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

HifiBerry raspberry pi 4 endpoints

Description Of Issue

I did migrate my Roon Core to an Intel NUC running ROCK. Everything works fine - only the Fan of the NUC is running constantly around 3800RPM. In the BIOS I did disable the Turbo Boost feature and tried different Cooling Settings. After Saving the settings and reboot of the NUC there is no change of the Fan behavior whatsoever. I can see in the BIOS the temperature is well below 40degree - but even when I choose the Fanless setting - the Fan still runs at around 3800 RPM. So I am thinking wether ROCK somehow overrides this settings? Or did I miss something else?
If that has nothing to do with Roon - I will contact Intel about it?
Thanks and best regards, Sven

How long ago? Is it still working on the library analysis…

Hi Ged, thanks - I migrated it yesterday - but I did restore a backup of my database to the new Core - and did not move any media files for now - so I am not sure - but I am guessing it should not do library analysis or anything else now. I am also not playing any music and I am not connected to any endpoint …

I recently installed ROCK and the fan settings where definitely not overriden by ROCK. Choosing the predefined settings (normal, quite , etc, don’t remember their exact names) clearly made a difference. So the issue probably lies somewhere else.

In the end I chose to transfer my NUC into a fanless case and I’m extremely happy about that. Maybe something you would want to consider.

Hi Anthony, thanks for letting me know. I will try to contact Intel Support tomorrow - let`s see. Also thanks for the link to the Akasa Case!
But can I ask you - even with different cooling settings - the NUC was not running “quiet” in the standard fan case?
best regards, Sven

I recently set up the same NUC you have and installed latest Bios and latest ROCK.
My fan is not noisy / hitting high revs, even when ROCK is building and analysing database.
Fan is on the normal setting.
If your fan is still speeding when ROCK is idling then maybe recheck Bios settings are saved, recheck the internal assembly (snugness of fitted hardware, cables, heatsink etc) and if all looks good talk to Intel and see what they have to say.

Even when choosing the “quiet” setting, the fan would keep spinning (low revs) and could only be heard when listening very closely with occasional boosts that were clearly audible from farther away. But during the first days I had the thing sitting on my desk just next to me, so maybe I got over sensitive about it. The fan in a NUC is very small and has very limited airflow, so it always has to work some to keep the system within working temperatures, which is why I opted for the fanless solution in the end.

I agree with @ogdens_sliced, check that the settings where correctly saved in Bios, in case you haven’t already.

Thanks @ogdens_sliced and Anthony for your Input. I actually did double check all is saved and I also reapplied the BIOS Update in case something did not work at first. Maybe I just picked up a faulty unit. But again thanks for your feedback - it is really helpful to get a feel how the NUC should work :slight_smile:
best regards, Sven

1 Like

I’ve read other posts on the fan noise but have not experienced it myself. Don’t know what the issue could be but I don’t think its normal, at least in my use. Ive had the NUC8I7BEH for a year now and have not heard the fan and it always seems cool to the touch. I did not do anything with the fan setting in the BIOS during the build, so default setting whatever that is.

It is located in a media closet with active cooling and it is possible the fan noise is masked by the normal sound level. I’ve had my ear right next to it and could not detect heat or noise after running 3 grouped zones all day long.

Good luck with the issue and please advise on what you find.

Thanks for all your feedback - I did contact Intel Support. As the Fan should not run at all when in BIOS Mode - which mine does - it seems to be a hardware issue. They suggested to replace the unit - which I will do. I will update the Post once I get the new NUC (next week). best Sven


Good to hear that the various people saying " mine doesn’t do that" helped :slight_smile:

Hi @Sven_Mechler,

Thanks for working with Intel to confirm this is a hardware issue, do let us know how the replacement NUC works!

Hi Noris and all, I received my replacement unit. This device is much quieter - comparing the two units - it is now obvious that something was not right with the first one. Thanks for your all your feedback :slight_smile:
I would have one further question. I already migrated the catalogue to Rock - my music files are still on my NAS. How do I best migrate the music files to the internal music storage of the Rock? Just copy the files to the inside storage and then update the database - or is there a better way to move the files “inside” Roon?
Thanks and best regards

Hi Sven,

You might review this FAQ to get an idea of how to migrate FAQ:_How_do_I_move_my_collection:

1 Like

Hi @Sven_Mechler,

Happy to hear the new NUC is working out nicely!
Yes, you’ll definiltly want to follow the instrucitons @Rugby linked:


If you are moving files between locations, drives, or machines, then it is best to avoid letting Roon see 2 copies of the same file at the same time:

  1. Be sure you have a current backup of your database before proceeding
  2. In Roon’s Settings > Storage , disable all old storage folders that contain the files that are being relocated.
  3. For performance reasons, if you are adding a large amount of music (1000’s of tracks), quit Roon (or stop RoonServer on Nucleus). The best experience will come from letting Roon look at the folders when the files have settled.
  4. Move/Copy the files
  5. If you stopped Roon in Step 2, start it again.
  6. In Roon’s Settings > Storage , edit the folders disabled in step 1 and change the folder location and re-enable it.
1 Like

Thanks @noris and @Rugby I will do so - appreciate your help :slight_smile: Sven

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.