Does the new Roon update work?

Quite funny: I was wondering where that new standby option selection is in German languge setup. Just not there. Switched to English and it appeared…

Running on a Nucleus +, all of my problems seem to be gone, things seem to happen much faster.

Working, however it needed to rebuild whole database which took some time. I assume that at NAS systems that can be reallllly long…

I run a Roon Core/Server on my MAC Mini (dedicated to Roon)and also use my MAC desktop as a remote so I can use custom Convolutions for Room Correction. All is good! I use an iPad Pro for remote control!

Finally I got my Roon Core back to work. After getting the “initialise” error and rebooting the Core software a couple of times on my Synology NAS, it started working again. I runs now as expected.

Actually very happy, because it fixed a major issue I had playing DSD tracks while using the Speaker Settings feature. It was not working before, and now it is, so as far as I’m concerned, this is a fantastic update.

1 Like

After some further investigation it appears they fixed my issue in Build 536, not 537.

Core on Windows 10: Build 536 updated without issue. Build 537 updated without issue. A-OK.

NO. It doesn’t work in my setup. Its a MacMini i5 with the most recent MacOS. The clients/remotes all went fine, the core not. After numerous reboots etc. the update procedure starts, downloads, starts to install and then stops with “Es ist ein Fehler bei der Update-Anfrage aufgetreten” (sorry for german)…

What to do? Stay with the older build?

Best wishes

Tag support to get it fixed

  1. Back up your Roon library.using Settings==>Backups==>Backup Now.
  2. Delete Roon from Mini. See this thread (among others) -
    How to uninstall Roon completely..DB or something appears broken
  3. Download and install a fresh Roon.
  4. Restore library using Settings==>Backups==>Find Backups

A recent backup is always good, but re-downloading Roon, copying it to the Applications folder (replacing the older version), and running it might be all that’s needed. I think this will kick off a database update if necessary.

1 Like

It worked. A complete reinstall and restore from backup fixed the issue…


1 Like