Double NAT w/ Virgin Media Hub, Superhub [Solution - Modem Mode]

It took me a while to get up and running, but that was mostly my own fault for running a double nat in my network. It hadn’t caused any problems up until now, but I needed to switch my Virgin Media hub to modem mode to get things working. Once I did that everything connected and seems to be working as expected. I’ll test more thoroughly over the weekend.

In the meanwhile, is there a list of encoding speeds that ARC will use? I ask as I can get lossless on wifi but am currently getting ‘Opus 256kbps’ on 4G. It would be useful to know the range of possible encodings to keep an eye on the quality of the connection.

Oh, and thanks for the invite. I’ve been looking forward to this for quite a few years :slight_smile:


Hey @DaveN,

I hope you don’t mind, but I’ve moved your description into a dedicated thread in our #arc-testing:port-forwarding-troubleshooting section since you described troubleshooting the automatic configuration. I’ll merge posts to sprinkle in troubleshooting nuggets related to the double-NAT scenario with your Virgin modem/router, as it’s one we’ll encounter frequently going forward.

ARC will use the encoding speed set in Settings → Playback. Cellular will default to lower quality for data use considerations, but if you set both WiFi and Cellular to “Original Format,” there shouldn’t be any discrepancies in different network situations.

1 Like