Downgrading Tidal HiFi to Premium - Roon frozen

Roon Core Machine


Networking Gear & Setup Details

Asus router ax11000 (LAN connection)

Connected Audio Devices


Number of Tracks in Library

± 7000 tracks

Description of Issue

I use Tidal and Qobuz. I changed Tidal subscriptions from Hifi to premium. Roon freezes and does not play music (neither Tidal or Qobuz) when I turn off the Tidal service in Roon and restart server, Qobuz works fine.

Any idea how to solve the problem??
BTW I do not plan to return to Tidal HiFi - not MQA lover :wink:

Cheers !!

Rather than disabling Tidal in Roon, I suggest logging out of Tidal, rebooting Roon and then logging back into Tidal once more. (This will force Roon to re-negotiate with Tidal so it knows what yous subscription is.)

Also in setting check that the Streaming Quality is set correctly.

Hi Carl. Thx for the message. Unfortunately the problem is not solved … I logged off Tidal in roon, → NAS restart-> logging Tidal in Roon. every attempt to play something from the tidal library causes crush … later nothing works … cannot be played with Qobuz, even mp3 from the library does not work … :frowning:

Hi @Przemyslaw_Lapeta, can you try this:

  • Exit out of Roon/Roon Server
  • Navigate to your Roon Database Location - Database\Registry\Core
  • Locate your tidal_account file and delete it

Also try clearing your cache:

After this please launch Roon and sign in to Tidal. After that let me know if there is any change here.

1 Like

Hi Dylan,
Thank you for your message!.
Unfortunately didn’t solve the problem… (BTW cache folder was empty… is it normal? actually NAS is rebooting automatically every night, maybe it’s cleaning cache files…"?")

Any other ideas?

Hello @Przemyslaw_Lapeta,

Thanks for trying out all the steps Dylan suggested :pray: . We’re only sorry it didn’t fix the issue already :pensive:

I was wondering if you could try this as well:

  • Stop RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database
  • Restore a backup

Thanks :pray:

I managed to reinstall roon… restore backup… Tidal is not playing and crash/freeze roon… problem not solve

Then your QNAP may be the problem.

Install Roon Core to a computer instead.

Hey @Przemyslaw_Lapeta,

Thanks so much for taking the time to try all the steps above. @wklie has a great point: could you please temporarily install Roon on a different device (a laptop or a computer) and see if the problem persists?

Hey Guys,
Yes Ill try to set roon on pc to see. To be honest i have no much hope… Qobuz is working fine if I turn of Tidal… and it was working before … problem start when I downgrade tidal subscriptions…
I don’t think it’s NAS fault … but I’ll try …

Did you install a user provided version of ffmpeg into your RoonServer on NAS? If not, there is no possiblity to playback AAC (what you get from Tidal after your downgrade).

Please read the thread I link below to find out why and how to do it if needed:


That’s a very good call. I forgot about the QNAP AAC problem.

If this is a missing CODEC issue, why doesn’t Roon display an appropriate error message?

Sample AAC can be downloaded from here to test in local library if necessary.

The Roon software doesn’t catch errors and presents an error message to users like other software (convenience, don’t bother users, what ever the reason may be for that) in many (most?) cases when things go wrong. In the best of such cases there is a meaningful entry in the log file.

Thanks a lot for your support guys. Unfortunately no success so far. ffmpeg did not solve the problem. now I’m going on vacation :slight_smile: I will try to reinstall Roon / transfer to pc (although this is not the solution to the problem) when I come back.

Maybe something went wrong with the installation of ffmeg - you wouldn’t be the first one. Please double-check to make sure that a newer ffmeg is used. I think also that you should turn off the DSD upsamling and make your system work without it first before you turn that on again.