Dragonfly Cobalt Missing from Audio Devices in Roon 2.0

I have the same issue. My Dragonfly Cobalt does not show anymore as a playable device in many Windows computers. Device works normally playing windows sounds, Spotify, Qobuz or anything. It is just not recognized by Roon anymore.


Roon Remote: Version 2.0 (build 1143)
Roon Optimized Core Kit NUC: Version 2.0 (build 1143)

Windows 10 Home
Version: 22H2
OS Build: 190452130
Experience: Windows Feature Experience Pack 120.2212.4170.0

Hi @Thiago_S,

Please accept my apologies for the long delay in responding. I’ve split your post into a new topic thread, as the old topic thread was a year old and irrelevant to Roon 2.0.

I recommend you take these steps to see if the Cobalt reappears:

  • Create a Backup of your current Roon database. This is essential retain custom DSP settings, playlists, etc. in your library.
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

We’ll be standing by for your response.

Hi, it didn’t work to me. Did exactly as instructed but still not able to see my Dragonfly Cobalt.
Any other suggestions?!

What is the use case? Are you running Roon on that PC? OR USING Roon Bridge to have that PC function as a network endpoint.

Either way, first thing to try is turning off the firewall on the PC and see if the DAC appears in the settings audio section.

Use case is trying to listen on a Windows PC running Room remote.
I have a server running on a NUC RoonRock.
It was working before, but it doesn’t anymore.

I will try the firewall option, but it seems unlikely because other softwares running on the same PC as Qobuz and Spotify can recognize the Dragonfly Cobalt.

TKS for the help anyways

Hi @Thiago_S,

I’m sorry to hear that the issue is persisting.

Can you please share a screenshot of your available Zones in Roon → Settings → Audio?

I’m assuming this USB DAC is visible in your Windows System audio settings since it plays back system output?

Also, do you have any additional audio drivers installed on this Windows device beyond ASIO/Wasapi? I’d make sure those are up to date, just in case.

Since it appears you’ve run RoonBridge on this same Windows device at some point, it might be helpful to perform the following to refresh conditions more broadly in your system.

  • First, create a Backup of your Roon database to retain custom DSP settings and other customization.
  • Uninstall Roon from your Windows remote.
  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your ROCK’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Reinstall Roon on your Windows remote from our Downloads page.
  • On all your Roon Remotes, press “Use another Core” and connect to the new database