Drop outs, lost internet connection while streaming over LAN

Hi all,

i’m impressed by the roon package. Very well done & keep on going.
Nevertheless i’m experiancing streaming issues which started from day 1( a couple of weeks ago).
I have worked on improving my network stability and did read a lot of comments in this forum.
I’m getting closer to the root cause and want to share some thoughts.
My set up is: cable internet(180/20)>Ziggo Cisco EPC3928 modem/router(bridged)>Asus RT-N16(Tomato 1.28)>QNAP TS251(8GB-QTS 4.3.2beta). The TS251 is running the Roonserver package as supplied by @Crieke. Roon installed on 256GB ssd.
Endpoints are Auralic Aries(wired) and Pi2b with HifiBerry HAT(wired) & Hifiberry roon image. Both end points are linked in one zone.
My remotes are Android tablets and a W10 pc.

The issue: streaming from the TS251 hdd works fine, streaming from Internet radio or Tidal Hifi is not.
Radio is much more stabile then Tidal but has ocassionial drop outs too.
I found out that the cpu load of the TS251 is quit high when playing Tidal. It can reach over 80%.
I also noticed that when it drops out it is while downloading a lot of data. This happens at the start of every new song.
I now have switched off all other applications on the TS251 and are just running Roon. That seems to be an improvement but needs longer time to conclude.
I do know that the minimal requirement for Roon is i3 but i’m surprised that the TS251 with intel celeron@2,4 Ghz is overloaded.

Would like to hear if there are any customers who are running Roon stable on the TS251.


No experience but from the dark recesses of my mind the words Jumbo Packets leapt out. You may need to check this is turned off on the router. It is a guess but worth looking at.

Thx Henry, just checked the router setting again. Jumbo frames is off.

Have you checked what happens if you use your QNAP as an audio endpoint (connect a USB DAC to it)?
I am wondering if there is a network related issue or if there might be a bottleneck somewhere in your network.
By connecting a USB DAC directly to your QNAP you could rule out 1 additional network route ( QNAP >> Auralic).

Is in this case the QNAP downloading a lot of data or some other device in your network?

I can understand you’re questioning the network. That were my initial thoughts too. I have made many changes in the last weeks and yes i made progress but still not 100% ok.
Because i do not understand what is going on i do not rule out the network as a root cause either.
Following your recommendations i have moved the TS251 near to the router so i could easily swap ethernet cables. No improvement. Then i moved the TS251 near to the Aries & amp, enabled the TS as endpoint and played directly from the TS251. No improvement either.

When i say downloading a lot of data then that is my interpretation of the network activity as displayed by the TS.
See the attachement. Incomming data is spiking every time when a new track starts. CPU load is spiking and sometimes this will result in lost connection/drop out and the next track will be started.

At the risk of stating the obvious: have you checked the NAS as well?

How many tracks are in your collection?

Not that much i believe.
There are an additional 2200+ mp3 tracks on the NAS but not in the Roon folders.


forgot to check the obvious…

Jumbo frames is set at 1500 on the NAS. I can’t switch off. The router tells me MTU is 1500. So this should be OK?
But i found out that the TS251 was set at a fixed ip. No problem but the router was set to reserve the same adres to this NAS but on a different subnet.
Maybe that caused some troubles?
I have corrected this. Wait and see.

Hi Jules,

I’ve been running the Roon server on a portable Samsung T3 SSD connected to my TS-251 without any issus.
Your configuration looks the same as mine except that I use a fixed IP address for the NAS.
As you experience no problems in streaming from your local network I suggest you check your internet speed with Ziggo speedtest.
My speed is 200 Mbps, but 100 Mbps should also be enough.
You should be sure that you use a USB 3 SSD connected to a USB 3 port on the NAS.

Speed is not the problem.

This is measured at the cable entering the nas.
I changed the ssd from front to back usb 3.0

After reboot i still notice very high cpu load but internet connection doesn’t drop out.

Once again wait and see.

Problem solved!

I moved the core to NUC6i5 Ubuntu 16.04 LTS. Not an easy for me being a Linux newbee.
Same network components, in fact the NUC is connected to the same ethernet cable as the TS was.
I must conclude that the Celeron j1800 cpu of my TS251 is too slow for running Roon smoothly.

Nevertheless, thanks for the tips & hints

1 Like

Interesting, I have a QNAP-TS651 with the same CPU (J1800) and my CPU usage is within 10%/20%, even when Roon is processing. I also have bunch of other apps (Plex, Sickrage, Ombi, CouchPotato, etc) and so far haven’t experienced any CPU bottleneck. I do have 8GB of memory and my library is even smaller with 5k songs or so (my endpoints are 7 Sonos speakers).
I’m planning to migrate Roon and Plex to a more powerful server but for now is performing according to my needs.