Dropouts on Ropieee

I too an getting dropouts on all my endpoints, wifi connected and ethernet connected. I have two raspberrys pis runiing ropieee, and a LH labs geek out on a windows 10 box. any ideas what might be going on.

thanks phil

Hello @Phil_Kemp,

I have split your post to better assist you here. Can you please let me know if everything is on the newest firmware for your endpoints? What kind of Core are you using? What is your network setup like? Please list the model/manufacturer of your gear.


I have split your post to better assist you here. Can you please let me = know if everything is on the newest firmware for your endpoints?=20

Yes everything is up to date

What kind of Core are you using?=20

Linux ubuntu=20

Linux siffleur 4.15.0-45-generic #48-Ubuntu SMP Tue Jan 29 16:28:13 UTC =
2019 x86_64 x86_64 x86_64 GNU/Linux

What is your network setup?

Ethenet to core and all endpoint.
100 Mbit internet connection

Please list the model/manufacturer of your gear.

Pc windows 10

  • Usb attached LH Labs geek out v2

Remote 1

      Raspberry pi 3b, hifiberry digi pro, toslink to parasound = zdac, ropieee 242

Remote 2

Raspberry pi 3b+, hifiberry digi pro, coax to Schiit bifrost, ropieee =

Do you need any more data?

Hi @Phil_Kemp,

Thanks for providing that info. I am curious to know your router’s model manufacturer since we have noted a few router that need special settings applied to properly work with Roon (as outline in our Networking Best Practices Doc) and wonder if your setup matches any of those.

Also, how are your Ropieee’s connected here? Are you making use of a switch anywhere or are they connected straight into the router? If they are on a switch, does the same behavior occur if you connect them directly to the router?

Does this issue affect just streaming content or does local content work as expected? Are you performing any DSP on the stream before it is sent to your endpoints? Does this issue affect higher resolutions more than lower resolutions? How often do you experience a dropout?


Router is an ASUS. Looks like streaming only shows the dropouts. I have tidal and Qobuz configured.

Ropieee are Ethernet connected. Through a switch and router. It never used to do this…

I can’t connect to the router directly. It’s too far from the audio equipment associated. With the ropieee’s…

I wonder if the streaming of both services causes the problem.

Let’s focus on that first.


I just disabled tidal and with quoboz alone i am still getting dropouts.


Hi @Phil_Kemp,

Thank you for trying that test. If the streaming services are the only one’s experiencing this issue, it could be due to bandwidth limitations on your network.

Connecting them via Ethernet will give us a good data point, and it is always useful to simplify your setup first, verify that everything works as expected and only after add complexity back in, so please try the Ethernet to router test for another good data point for this issue.

If you would like to see a more expansive list of why this issue could possibly occur, I would also suggest taking a look at our troubleshooting audio dropouts guide for more information in that regard.

What are the specs for your machine? How much RAM and what kind of CPU does it have? Are the local files that are working lower resolution than the files you are trying to stream? Does the same issue occur if you try to output to “System Output” on your Ubuntu Core? Please let me know when possible.


as stated before, all the devices, core and endpoints are ethernet connected. i have 100 Mbps at least to all devices in the network.

my internet service is 1000 Mbps and I getting around 800 Mbps using speedtest.

the core has been running for over two years without a problem. it is a 4 core AMD with 32 GB ram.

the local files which are working are at least 44.1 k and up to 192 k.

I will test the core out tomorrow.

can you tell anything from the logs? shall I send you copies?


heres the exact processor model. i have 8 cores not 4…

AMD® Fx™-8350 eight-core processor × 8


OK, so i did some troubleshooting. i tried the windows pc as core. no dropouts on the streaming services. so i rebooted the ubuntu core. now i am not getting the dropouts on the stream services with the ubuntu core.

is it possible that there are some raatserver/roonserver issues that accumulate on linux that cause the dropouts? can you suggest any tuning of the ubuntu core that might prevent this in the future. i can certainly reboot the core once in a while, but i shouldn’t have to.

any thoughts?


Hi @Phil_Kemp,

Glad to hear that rebooting your Core resolved this issue. No need to send us the log files, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

One thing that I would make sure you have here is the latest Ropieee firmware. On the Ropieee site, I can see that there was a version released on 2/26/2019, which is fairly recently. Can you let me know if you have this version installed? It may contain improvements regarding the issue you experienced.


I did make sure I had the latest ropieee sw… let’s see how things go… so far so good!


Hi @Phil_Kemp,

Happy to hear that things are working as expected!

I did notice the diagnostics from your machine come in and they report that the connection to your Ropieee’s timed out but do not see any further information other than that.

If things are working ok after the reboot it is possible that this was a temporary issue due to something in your networking environment that has since been reset, but if it happens again do let us know (hoping it won’t though :slight_smile: ).


I updated the firmware on my router just to be sure it was at the latest level… that was probably the timeout. thanks for checking … will keep you up to date.

1 Like

I just gave RoPieee a try for the first time this week…with the 7" Raspberry Pi touch screen. I’m using a Raspberry Pi 3 Model B+ in a SmartiPi case. It looks quite nice, apart from the Legos on the front. :slight_smile: I’m running the 20190518 release of RoPieee. Roon Server is a NUC8i3BE ROCK build, networked via 1 Gbps wired Ethernet.

Like others here (although the root cause may be different), my listening experience has been frustrated by occasional dropouts (sounding almost like “pops and clicks” from the vinyl days). At no point has playback been interrupted; however, the dropouts were frequent enough (perhaps a few dozen per song) to be irritating.

While not a 100% fix, it seems that lowering the priority of the touch UI has virtually eliminated the problem. To persist the change across reboots, I just added "Nice=19" to the systemd startup (/etc/systemd/system/ropieee-touchui.service). For example:

ExecStart=/opt/RoPieee/touch/ropieee-touchui -platform eglfs

Here’s a Perl one-liner that implements this edit for those who are not comfortable with text editors on Linux:

perl -ni -e 'print unless /^Nice=/; print "Nice=19\n" if /^ExecStart=/;' /etc/systemd/system/ropieee-touchui.service

With this change, the touchscreen still seems to be quite responsive. There may be other RoPieee processes (like ropieee-web.service) that could be deprioritized as well to further improve performance. Changing that too would look like this:

perl -ni -e 'print unless /^Nice=/; print "Nice=19\n" if /^ExecStart=/;' /etc/systemd/system/ropieee-{touchui,web}.service

I may experiment with adding a few more, but you get the idea. Hope this helps.

– David

It would be lovely to see this change baked into future releases (hint, hint) :slight_smile:

Lowering the priority of the remote service seems to have helped further:

perl -ni -e 'print unless /^Nice=/; print "Nice=19\n" if /^ExecStart=/;' /etc/systemd/system/ropieee-{touchui,web,remote}.service

As a reminder, to run this command, you have to login to your RoPieee as root. Password is “root”.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.