Dropouts towards the end of long tracks

That is interesting. Most of the dropouts I get are towards the end of long tracks (symphonies, for example). I’ve had this problem, for example, while listening to the Shostakovich symphony no. 11. The second, third, and fourth movements flow into each other. Towards the end of the second movement there are a few seconds of silence interspersed with plucked double bass. Roon always skips at the same point from the second to the third movement (about five seconds out from the end of the second). If I recue the second movement and play from near the end, then it plays through. I remember reading in one of the posts of the ROON support staff that Roon interprets three seconds of silence over a specified playback period as the end of a track, and skips on to the next. I wonder if this is what is happening? Except that the silences are intentional on the part of the composer!! When I listen to pieces with shorter movements there is no problem, or when long tracks don’t flow into each other.

I have a gigabit network, an I-5 computer with 8gb memory, a fast SSD, and a Roon endpoint comprising the Raspberry Pi 2B and HifiBerry Digi+, Modi Multibit with a SPDIF Ipurifier between the Digi+ and the DAC. Sound quality is pretty outstanding.

I wish Roon 1.3 would address this problem. At the moment, there is a bug in the program they need to address, but I’m not sure anyone at Roon is listening.

Well, your issue seems to be specific in that you want Roon to identify and correct what happens when there is a purposeful 3 seconds of silence at the end of a piece. Since that is not the same as the original post, I suggest you make a new post specifically about this. @andybob may be able to split this into its own new topic.

Hi @sucheta_mazumdar,

Carl has split your post into this new thread (thanks @rugby) in order for @support to look into it individually. Post here again if there is anything relevant we have left in the other thread.

I’m not sure anyone at Roon is listening

Let’s see if we can alter that impression :wink:

1 Like

Thanks for getting back to me. I’m not sure how this all works. But could it be something like a “time-out” issue? What I mean is if Roon Server encounters a specific number of seconds of silence over a specific period of play it jumps ahead to the next track? In the example I mentioned the silences accumulate towards the end of a movement. And that is when Roon jumps to the next track.

If true, then couldn’t it be dealt with by increasing the “time-out” to say 10 seconds or giving users an option to set it (within limits). Or, at least try it out as an option and see if that corrects the problem?


@andybob ---- Thanks for flagging me down here :muscle:

Hi @Sucheta_Mazumdar ----- Thank you for the report and my apologies for the troubles here. To help me accurately evaluate this issue you are experiencing may I kindly ask you for the following information:

  1. An expanded description of your current setup as seen here. The more detail you can provide, the better.

  2. Can you verify if you have crossfading engaged while you are listening to music in Roon? Please provide screenshots of your zone settings as well as your playback settings.



–Lenovo X-250 laptop, with 8gb memory, 128gb hdisk, Windows 10 Enterprise, Fidelizer Pro 7.5, 64-bit ROON Server.
–Approximately 8,000 tracks (mostly classical), listen to my CD collection and Tidal.
–Roon endpoint is: Raspberry Pi2B, HiFiBerry Digi+

–Crossfade is not engaged.
–Wired ethernet gigabyte network. (Ubee modem/router provided by Time-Warner).

–As noted, the dropouts seem only to happen when playing long tracks back to back where one track flows into the next. This doesn’t happen with short tracks.

–Not sure if I left anything out.

In addition to all the other stuff I’ve sent, can I also send you the log.txt? If so, should that be from the computer that has Roon Server on it? Or the laptop I use as control point?

(Incidentally, I had the same thing happen today: a few seconds dropped at the end of a long movement). It’s just frustrating because otherwise there are so many things about Roon that I like. Basically, something about the streaming convention that Roon is using seems not able to discriminate between intentional silences and whatever in the software is triggering the termination of one track and the transition to the next. I’m hoping someone at Roon will get to the bottom of this.


Hi @Sucheta_Mazumdar ----- Thank you very much for the follow up and the feedback, both are appreciated :clap:

Moving forward, I would like to try and reproduce this behavior in house. Are you able to send me sample of the content you are noticing this behavior with via a dropbox download link in a PM?