Dropouts when using playing back to remotes

Tried the settings - private zone “no” and 48kHz.
Doesn’t work. Music starts to stuck after 20 to 30 seconds when in background…

So new Roon 1.6 (Build 401) didn’t make it better. Someone else can confirm this?

1 Like

Thanks for your feedback - thought I was the only one - tried it with 3 different smartphones now - 2 s9 with different firmware releases and one s8…

Thanks a lot
@support
Smebody s taking care of that please…

Can confirm this on a surface go…

Hi @Ernst_Ellensohn,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

What endpoint were you playing to when this occurred? Directly to the Surface?

We have a ticket open with our development team regarding this behavior — This type of issue requires a pretty major overhaul of how playback works on the Android app. I can’t provide any specific timeframes, but this is something we are planning to address in the future.

This type of behavior is a bit different than what you reported with the Windows remote, so some additional information about your setup will definitely help us understand why that’s occurring.

Hi Dylan,

so you don’t really need more infornation about the android problem on my S9.

That’s my main problem an easy to reproduce every time.

The surface go is “only” for controlling my Linn Akurate DSM. So I don’t listen regulary over the surface directly. But when I read about the problems of andre_klap I tried it - and had same problem - but only twice - and had to listen for about one hour. I can try it maybe next weekend if I can reproduce.

Hi @Ernst_Ellensohn,

Regarding the Android issue, we are currently investigating as mentioned by Mike here:

As mentioned by Mike there, I would definitely make sure that battery optimization settings are disabled for Roon and see if that yields any improvement. Beyond that, we have a ticket open with our development team to investigate.

Thank you. It seems that it has to do with battery optimization. I tried to switch off and set to max. power.
That helped a little bit. Dropouts came after 2 minutes - but they came. I didn’t find any settings that made it possible to listen to a whole song without problems when Roon is in background. I hope that you find something to fix that problem…

Something strange happened - I always spread 2 Wlans 2,4 and 5G. Don’t know why - but turned off the 2,4 and now operate only the 5G - the problem has gone - listening for 30 min. now - no dropout. So it was a network problem?! Hope that it was… Thanks a lot for your support…

Oh no - was an coincidence - it was the album i listened to - when listening to 48kHz/24bit is much better than 44.1kHz/24bit. Any idea???

Hi @Ernst_Ellensohn,

Is this always the case? When listening to 44.1 does this always happen, but never with 48?

@support
When listening to 44.1kHz it always happened – fastest when switching off the screen – after maybe 30 seconds the music got completely stuck.

With 48kHz I had maybe one or two small clicks in about 3 minutes.

Thanks for confirming that, @Ernst_Ellensohn.

Based on the symptoms, it still sounds like you’re experiencing the issue mentioned below:

I’ll be sure to pass it along to the team that you’re only experiencing this with 44.1KHz and we will be sure to keep you updated when we have new information regarding the above issue.

Thanks!

@dylan
So some time has gone - something new?
Still have this annoying behaviour.
Thanks for your reply…

+1 For this problem on a Galaxy S9+ with a Roon ROCK core. Have tried battery management tweaks, but still getting distortion 30 seconds after switching Roon app to background when playing back to phone.

Hope you can resolve, as I would like to use phone for playback.

Thanks

@dylan
That’s exactly what happens with my Samsung S9 with Roon ROCK.
30 seconds…

Hi @Ernst_Ellensohn / @Mark_Pocock,

I want to mention that we have an active investigation regarding this issue, we believe to know why it occurs and the devs are currently working on this issue along some improvements to our Android app.

I can’t comment on when the new version of the Android will be published, but just wanted you to be aware that work is in progress on this area, and we are hopeful that it will help in your cases as well.

Just coming around - something new?
4 month have gone…

Hi @Ernst_Ellensohn,

I just checked out internal ticket tracker regarding this behavior and I see that we are still actively working on this issue for our next release, we have made quite a few changes regarding Android playback.

I can’t comment on when the next release will be published, but once the new release has been published, we can circle back to this issue and take another look. I appreciate your patience until then!