DSD nativo in kernel ubuntu studio 18.04 for USB Audio DAC CAYIN

Good morning, I have installed on a NUC i7 that I have version 18.04 of ubuntu studio in its desktop version. On it I have installed roon core server and hqplayer4 desktop, everything works fine and I have access from my mac with XQuartz to hqplayer. The NUC connects to the Cayin DAC via usb audio. The only problem is that the native DSD does not detect me. I have seen that in the signalyst page appear Custom Linux kernel packages for native DSD support inside the directory come several subdirectories such as bionic, buster, f25 and focal, with all this:
1º Can I install any of those kernels so that native dsd works?
2nd If so, which deb file should I use to make it work considering my version of Ubuntu?
3rd If the above is not possible, is there a version of linux where it has native dsd in the kernel or is compatible with the files mentioned in signalyst ?.

Thanks and regards

Hi Miguel,

This is how I did it. (Copy/paste from my thread in Tinkering):

  1. Low Latency Kernel with native DSD support

I found these commands to install Jussi’s low latency kernel in this guide to installing HQPlayer Embedded.

wget http://www.sonarnerd.net/src/bionic/linux-image-4.14.71-jl+_1_amd64.deb
wget http://www.sonarnerd.net/src/bionic/linux-headers-4.14.71-jl+_1_amd64.deb
dpkg -i linux-headers-4.14.71-jl+_1_amd64.deb
dpkg -i linux-image-4.14.71-jl+_1_amd64.deb

Ubuntu uses Debian package files.

The latest versions of Jussi’s files can be found here and should be substituted into the above commands. When I did it 5.4.50 was the latest version.

As a tip for young players trying to distinguish their l’s from their 1s in the filenames: they are all the lowercase letter l except for 1_amd64.deb which is a numeral 1.

I suspect Cayin DAC VID PID is not registered in mainstream Linux native DSD table. Unless Jussi has added that from prior customer report, I’m not sure using a different kernel will allow the OP to use native DSD. That being said, once the Cayin VID PID is found, it should be possible to patch the kernel to support it since it may be using XMOS.

Thanks for your answers, I have received this message from Jussi:

You can find experimental support for the Cayin DAC in my latest 5.4.72 kernel here:


### Index of /src/focal/

This kernel is for Ubuntu 20.04. You need both the “headers” and “image” version of the package. Then install it with:
“sudo dpkg -i linux-headers-5.4.72-jl+_5.4.72-jl±1_amd64.deb linux-image-5.4.72-jl+_5.4.72-jl±1_amd64.deb”

On next reboot it should boot automatically to this kernel. You can verify with “uname -a” after reboot.

And this is my answer:
Hello Jussi, I have heard what you have told me. I’ve previously upgraded to 20.04 and it still doesn’t work. When applying the command “uname -a” I get the following result: ~ $ uname -a
Linux ubuntu-desktop 5.4.0-52-lowlatency # 57-Ubuntu SMP PREEMPT Thu Oct 15 12:05:45 UTC 2020 x86_64 x86_64 x86_64 GNU / Linux. Any ideas. Thanks and regards.

Can you help me? Thanks and regards

Solved thank to Jussi !!! it was a grub issue that was not configured correctly to boot into the correct kernel. Now my Cayin works on native dsd. Thank you very much for your implementation in the kernel.

1 Like

I’m glad you got it working.

Could you run the following command in a Ubuntu terminal and show your results? I’d like to confirm the Cayin VID PID (in another forum [Edit] a wrong VID PID was stated). Thanks.


And exactly which model of Cayin are you using?

Hi, this is the answer to “lsusb”
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2b Intel Corp.
Bus 001 Device 002: ID 2d87:000a Cayin Cayin iDAC-6
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

My Cayin DAC is Cayin iDAC-6 mk2

1 Like

Hi does the Ubuntu server 20.04 has native support for DSD?

Yes, depending on your DAC. For some extended support you can use my custom kernel build referred earlier.

I’m having a similar problem with an iDACi6 MK2 - can’t playback native DSD, only DoP.
I’m using HQP desktop in Windows 11, and and an RPi4 running dietpi OS with HQP NAA that connects via USB to the DAC.

I’m not sure I’m totally understanding this thread.
Is the solution for me here, too?
If so, can someone write the lines of code I need for the dietpi install in order to update the kernel and play native DSD?