DSP convolution running on core or endpoint

I’m trying to use DSP convolution (6 channel crossover + room correction). I have success on running it on a PC running the Roon App on Windows 11 as a trial, with output going to a USB device with ASIO driver (the device support 6 channels native).

My question is if I want to have the USB device connected to a Roon bridge instead in order to separate from the core function, will the DSP convolution be running on the core or on the bridge? My understanding is that it should be on the core but I cannot find any reference how it would support a multi-channel setup. Could you please clarify. I am trying to understand if I need a higher CPU power device for the bridge, or a Pi endpoint would suffice.

Hi, welcome!

DSP runs on the core, so you don’t need a powerful machine to run the bridge. A Pi will be enough. Roon can stream multichannel audio.

Thanks. The multi-channel seems to work and the channel mapping is correct. However, I have two unused channel that is now flooded with noise. The device is actually a 8-channel capable USB device. I’m only using the first 6 channels. When connected directly to the core machine via USB, there is no noise output to the 2 unused channel. When going through a Roonbrigde, the unused channel is flooded with full scale noise. Is there anything I can do to disable the noise output on the two unused channel? May be in the convolver cfg files?

Can you share the signal paths for both cases, i.e. local vs. remote?

For Local:
Roon App on Windows 11 → USB DAC using ASIO driver → 6 channels of amplifier

(Note that DAC is a RME ADI-2 Pro R FS BE in mutli-channel mode which support 8 channels of output over USB. I’m only using the first 6 channels)

For Remote:
Roon App on Windows 11 (use as Core) → Ethernet → RoPieee → USB DAC using ALSA driver → 6 channels of amplifier

I suspect the problem arise at the Roonbridge when it received only 6 channel of data and was asked to output 8 channel to the device.

This is what a signal path looks like:


You need to click on the signal quality indicator during playback:

The problem seems to have go away after I rebooted the bridge. Seem to be a corner case where the output buffer is not properly initialized (probably when I was changing audio output configuration). I will provide the signal path once I reproduced the problem.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.