DTS CD gives static on HDMI to denon AVC-X6700H

Hi Henry,
Not sure which setting you refer to, I’ve tried setting in Pure, Direct, Pure Direct, all the same.

The receiver actually displays multi-ch in, which I believe should be DTS instead.
When it worked suddenly this morning, I could see that difference.

Frank, are you sure this “CD 5.1” is a “DTS 5.1” cd, and not a 5.1/44.1 flac rip?
Could you check?

In the audio menu of the amp you should be able to select how you want it to treat an incoming bitstream,

Hello Guido.

You are right, it is a 5.1 surround rip - my appolgies. I just ripped the dts cd via Foobar. So thats no use in your case.

To be clear, to be encoded as CD, it appears to be a stereo file. The surround channels are encoded in the DTS. So it needs to be treated as stereo until it hits the decoder in the amp.

Yes I believe that’s part of the problem, the fact that the mac sends it as 8 - channel multi in is not good, even though I force it stereo, input stays multi.
In fact changing to any surround audio mode, keeps stereo, meaning the multi channel bit transfer overrules the audio modes, in case of stereo there is in fact front left + right playing, and empty center and surrounds are also transferred between Mac and the Denon.
With 5.1 flac all channels are transferred then.
This probably causes the issue for the DTS mode.

I’ve noticed instances on my Denon 8500H when it displays Multi-Ch in. I can use the Denon info button to display the signal being decoded. Other times it has displayed the signal type.

Hi Mike,

I know very well, it’s there I see that I only get always Multi 7.1 in from the Mac. (Even sending Stereo from Roon) This is the issue, I cannot select any sound mode as the 7.1 always is preserved.
If I could find a way to ensure 2.0 over HDMI I think my issue is solved.

What is “Enable Integer Mode” for? Is it possible it is altering the DTS signal?

Also, under Zone Settings, is Volume Leveling off? (Edit; nevermind, I can see in your signal path this is off).

Did you try turning Exclusive Mode off?

(It works fine with my Salkstream III hooked to my Oppo 103 via HDMI, so I’m trying to see any place where my settings differ from yours.)

Thanks for your feedback Saturn94, I tried with Exclusive mode off, same issue.
Integer Mode off or on does not make a difference either.
If you put Exclusive mode off, you’ll get this (not a purple/pure signal path anymore)


My hope is when profile is added for the AVC-X6700H (I am using 6500 currently as my new type is not available) that you can actually restrict the channels to 2.0, instead of the always selected 7.1 in the HDMI link, I am not able to enforce in channel layout, neither on the MacOS. (audio/midi app).
This would solve the issue for the DTS CD Rip playback.
It would also enable to utilize all the nice sound modes in the amp, as currently 7.1 multi-channel prohibits this also. I saw related posts on this forum about this as well on some devices.


Hi @Guido_Jongbeis,

As per our File Types FAQ, DTS is not a file format that we support, and as such we cannot make any guarantees that it will play back properly through Roon.

If this issue also ends up impacting regular FLAC files, it could also be a HDMI handshake issue where the AVR is reporting the wrong amount of channels.

Well, it’s not such much anymore as to DTS is supported or not, but I feel the setting within device settings / channel mapping to the Denon device is not working 100%. When I set 2.0, I would expect Roon to switch to a 2.0 configuration on the HDMI (enabling all the nice audio modes), while 7.1 I would expect multi-channel 7.1 to be enabled.
This seems not the case currently. I wonder if that would change once the 6700 profile is added within Roon. I am not sure if that works correctly today on any of the models. I get the impression always roon sets it to maximum, and the setting in device setting, is useless.
Having this resolved, I believe the DTS will come automatically fixed.
Make sense?


Best to leave it set to 7.1 at all times. Roon will itself switch to 2.0 for stereo/mono material. See here:

Roon 1.3 Build 242 contained a change to our default stereo/mono playback behavior when talking to multi-channel devices. Previously, the full channel layout was always sent, with silence sent to unused channels. Now, stereo/mono content is sent using the “2.0” layout, and only multi-channel content uses the selected layout. This setting allows users to revert to the old behavior if desired, but we expect that the default will work for the great majority of use cases.

Well, interesting info around Build 242 as this is not the behavior I am getting, it’s full channel layout always. Are we sure this is still active in 1.7 (610)?
I verify this with the input indicators on the device.
When would the profiles for the denon 2020 avr’s be added?

What have you got as your Roon settings? My Roon is behaving as stated in the KB article, and switching between 2.0 and 7.1 on my Denon 3808 AVR…

(I have the Denon set to play 7 channel stereo when it receives 2.0 material)

Indeed, and this is not working for me, I am playing and setting 2.0 channels, look

See? Maybe it’s because I am using a denon 6700 with a 6500 roon device setup, but I don’t have the 6700 type available? Using an unidentified device, also gives 7.1 always.

But why are you setting 2.0 channels in the Roon Device setup screen? It should be 7.1…

That does not make a single bit of difference.
5.1, 7.1, 2.0 all the same.
Reason for 2.0 is because of the DTS cd’s. But all give the same.

Then all I can think of is that it is something to do with the fact that you are running your Core on MacOS and I am running on Roon OS (using a NUC/ROCK). I notice that my Device settings items are not all the same as yours:

@support - any comments?

1 Like